nyoj364(田忌赛马)

nyoj364(田忌赛马)

大体题意:田忌与国王赛马,赢一局田忌加200,输一局田忌减200,问田忌最多能得多少钱,可以是负的

输入
The input consists of many test cases. Each case starts with a positive integer n (n <= 1000) on the first line, which is the number of horses on each side. The next n integers on the second line are the speeds of Tian’s horses. Then the next n integers on the third line are the speeds of the king’s horses.
输出
For each input case, output a line containing a single number, which is the maximum money Tian Ji will get, in silver dollars.

样例输入
3
92 83 71
95 87 74
2
20 20
20 20
2
20 19
22 18
样例输出
200
0
0

解题思路:

贪心贪赢,从大的开始比较,如果大的比较可以赢,就让大的比,

目的:为了己方小的与对方大的比较时赢得胜利的几率增大,如果大的赢不了,

先不认输,让小的比较,赢了就比,赢不了,就拉上对方大的(为什么还要比较?

因为前几次都没有比较是否相等,此次是为了让输得次数加一,有可能己方小的与对方大的相等),为了下一次大的比较时,让己方大的赢得几率大。

贪心贪两方面:
1.贪本局赢(多赚钱)
2.贪队友赢(为队友留下更大赢得几率)


#include <stdio.h>
#include <algorithm>

int tian[1000];
int king[1000];
int result, n;

int getres()
{
    result = 0;
    int nk = n-1, ks = 0, tk = 0;
    n--;
    while (true)
    {
        if (tian[n] > king[nk])         // 大的可以赢,为小的与大的比较时留下赢得希望
        {
            nk--;
            n--;
            result += 200;
        }
        else if (tian[tk] > king[ks])   // 小的可以赢,可以赢就赢白,别浪费了
        {
            ks++;
            ++tk;
            result += 200;
        }
        else if (tian[tk] < king[nk])   // 小的输了,拉大的下马,为大的比较留下希望
        {
            nk--;
            ++tk;
            result -= 200;
        }
        else                            // 平局
        {
            ks++;
            ++tk;
        }
        if (ks > nk)
            break;
    }

    printf("%d\n", result);
}

int main()
{
    while (~scanf("%d", &n))
    {
        for (int i=0; i<n; ++i)
            scanf("%d", &tian[i]);
        for (int i=0; i<n; ++i)
            scanf("%d", &king[i]);
        std::sort(tian, tian+n);
        std::sort(king, king+n);
        getres();
    }
	return 0;
}

  • 0
    点赞
  • 1
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
孪生素数是指个素数之间的差值为2的素数对。通过筛选法可以找出给定素数范围内的所有孪生素数的组数。 在引用的代码中,使用了递归筛选法来解决孪生素数问题。该程序首先使用循环将素数的倍数标记为非素数,然后再遍历素数数组,找出相邻素数之间差值为2的素数对,并统计总数。 具体实现过程如下: 1. 定义一个数组a[N,用来标记数字是否为素数,其中N为素数范围的上限。 2. 初始化数组a,将0和1标记为非素数。 3. 入要查询的孪生素数的个数n。 4. 循环n次,每次读入一个要查询的素数范围num。 5. 使用层循环,外层循环从2遍历到num/2,内层循环从i的平方开始,将素数的倍数标记为非素数。 6. 再次循环遍历素数数组,找出相邻素数之间差值为2的素数对,并统计总数。 7. 出总数。 至此,我们可以使用这个筛选法的程序来解决孪生素数问题。<span class="em">1</span><span class="em">2</span><span class="em">3</span> #### 引用[.reference_title] - *1* [python用递归筛选法求N以内的孪生质数(孪生素数)](https://blog.csdn.net/weixin_39734646/article/details/110990629)[target="_blank" data-report-click={"spm":"1018.2226.3001.9630","extra":{"utm_source":"vip_chatgpt_common_search_pc_result","utm_medium":"distribute.pc_search_result.none-task-cask-2~all~insert_cask~default-1-null.142^v92^chatsearchT0_1"}}] [.reference_item style="max-width: 50%"] - *2* *3* [NYOJ-26 孪生素数问题](https://blog.csdn.net/memoryofyck/article/details/52059096)[target="_blank" data-report-click={"spm":"1018.2226.3001.9630","extra":{"utm_source":"vip_chatgpt_common_search_pc_result","utm_medium":"distribute.pc_search_result.none-task-cask-2~all~insert_cask~default-1-null.142^v92^chatsearchT0_1"}}] [.reference_item style="max-width: 50%"] [ .reference_list ]

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值