poj 2853

Sequence Sum Possibilities
Time Limit: 1000MS Memory Limit: 65536K
Total Submissions: 5434 Accepted: 3578

Description

Most positive integers may be written as a sum of a sequence of at least two consecutive positive integers. For instance,

6 = 1 + 2 + 3
9 = 5 + 4 = 2 + 3 + 4
but  8 cannot be so written.

Write a program which will compute how many different ways an input number may be written as a sum of a sequence of at least two consecutive positive integers.

Input

The first line of input will contain the number of problem instances N on a line by itself, (1 ≤ N ≤ 1000) . This will be followed by N lines, one for each problem instance. Each problem line will have the problem number, a single space and the number to be written as a sequence of consecutive positive integers. The second number will be less than 231 (so will fit in a 32-bit integer).

Output

The output for each problem instance will be a single line containing the problem number, a single space and the number of ways the input number can be written as a sequence of consecutive positive integers.

Sample Input

7
1 6
2 9
3 8
4 1800
5 987654321
6 987654323
7 987654325

Sample Output

1 1
2 2
3 0
4 8
5 17
6 1
7 23

Source

对于k和连续的个数i,以前总喜欢凑使它们满足(k+k+i-1)/2=m,费时啊
这里可以先举出一个i,看k是否符合,大概就这样
#include<iostream>
#include<cstdio>
#include<cmath>
using namespace std;
int main()
{
    int n,m,num,l,ans;
    scanf("%d",&n);
    while(n--)
    {
        scanf("%d%d",&num,&m);
        l=sqrt(2*m);
        ans=0;
        for(int i=2;i<=l;i++)
        {
            if((2*m)%i==0&&(2*m+i-i*i)%(2*i)==0)ans++;
        }
        cout<<num<<" "<<ans<<endl;
    }
    return 0;
}


评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值