poj 1716

Integer Intervals
Time Limit: 1000MS Memory Limit: 10000K
Total Submissions: 11866 Accepted: 5007

Description

An integer interval [a,b], a < b, is a set of all consecutive integers beginning with a and ending with b. 
Write a program that: finds the minimal number of elements in a set containing at least two different integers from each interval.

Input

The first line of the input contains the number of intervals n, 1 <= n <= 10000. Each of the following n lines contains two integers a, b separated by a single space, 0 <= a < b <= 10000. They are the beginning and the end of an interval.

Output

Output the minimal number of elements in a set containing at least two different integers from each interval.

Sample Input

4
3 6
2 4
0 2
4 7

Sample Output

4

Source


0 1 2 3 4 5 6 7
-----           (0 to 2)
    -----       (2 to 4) 
      -------   (3 to 6)
        ------- (4 to 7)
数据如上,要找的就是一个集合,集合与数据的每个集合的交集至少有2个元素,求集合最少的数的个数。
贪心:先按照结尾数排序,第一个集合找末尾2个数,第二个集合,现根据前面判断已经有几个数在交集中了,如果够2个就跳到第三个集合,如果不够就从末尾找,往前补够2个,第三及以后的类推。
#include<iostream>
#include<cstdio>
#include<cstring>
#include<algorithm>
using namespace std;
struct node
{
    int a,b;
}p[10005];
int n,ans;
bool cmp(node x,node y)
{
    return x.b<y.b;
}
bool v[10005];
int main()
{
    while(scanf("%d",&n)!=EOF){
    for(int i=0;i<n;i++)scanf("%d%d",&p[i].a,&p[i].b);
    sort(p,p+n,cmp);
    memset(v,0,sizeof(v));
    v[p[0].b-1]=1;
    v[p[0].b]=1;
    ans=2;
    for(int i=1;i<n;i++)
    {
        int num=2;
        for(int j=p[i].a;j<=p[i].b;j++)
        {
            if(v[j]==1)num--;
        }
        if(num>0)
        while(num)
        {
            v[p[i].b-num+1]=1;
            ans++;
            num--;
        }
    }
    cout<<ans<<endl;}
    return 0;
}


  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值