路由 rip

作业1:100.10.12.5 ping通100.10.34.5的路由设置


==R1==================================
--设置 e0/0 ip
show ip interface brief
config
int e0/0
no shutdown
ip address 100.1.12.1 255.255.255.0
end

R1#show cdp neighbors
Capability Codes: R - Router, T - Trans Bridge, B - Source Route Bridge
                  S - Switch, H - Host, I - IGMP, r - Repeater

Device ID        Local Intrfce     Holdtme    Capability  Platform  Port ID
R2               Eth 0/0            156        R S I      3640      Eth 0/0

--设vty 密码和enable 密码
config
line vty 0 4
password 123
exit
enable password 123
service password-encryption

--加一个loopback,模拟一台主机
configure
int lo 0
ip address 100.10.12.5 255.255.255.0
end
show ip interface brief

--设动态路由 rip
configure
router rip
version 2
no auto-summary
network 0.0.0.0
end

==R2==================================

show ip interface brief
config
int e0/0
no shutdown
ip address 100.1.12.2 255.255.255.0
exit
int e0/1
no shutdown
ip address 100.1.23.1 255.255.255.0
end

R2#show cdp neighbors
Capability Codes: R - Router, T - Trans Bridge, B - Source Route Bridge
                  S - Switch, H - Host, I - IGMP, r - Repeater

Device ID        Local Intrfce     Holdtme    Capability  Platform  Port ID
R3               Eth 0/1            129        R S I      3640      Eth 0/1
R1               Eth 0/0            159        R S I      3640      Eth 0/0

config
line vty 0 4
password 123
exit
enable password 123
service password-encryption

configure
router rip
version 2
no auto-summary
network 0.0.0.0
end
==R3==================================
show ip interface brief
config
int e0/0
no shutdown
ip address 100.1.34.1 255.255.255.0
exit
int e0/1
no shutdown
ip address 100.1.23.2 255.255.255.0
end

R3#show cdp neighbors
Capability Codes: R - Router, T - Trans Bridge, B - Source Route Bridge
                  S - Switch, H - Host, I - IGMP, r - Repeater

Device ID        Local Intrfce     Holdtme    Capability  Platform  Port ID
R2               Eth 0/1            127        R S I      3640      Eth 0/1
R4               Eth 0/0            137        R S I      3640      Eth 0/0

config
line vty 0 4
password 123
exit
enable password 123
service password-encryption

configure
router rip
version 2
no auto-summary
network 0.0.0.0
end
==R4==================================
show ip interface brief
config
int e0/0
no shutdown
ip address 100.1.34.2 255.255.255.0
end

R4#show cdp neighbors
Capability Codes: R - Router, T - Trans Bridge, B - Source Route Bridge
                  S - Switch, H - Host, I - IGMP, r - Repeater

Device ID        Local Intrfce     Holdtme    Capability  Platform  Port ID
R3               Eth 0/0            175        R S I      3640      Eth 0/0

config
line vty 0 4
password 123
exit
enable password 123
service password-encryption

configure
int lo 0
ip address 100.10.34.5 255.255.255.0
end
show ip interface brief

configure
router rip
version 2
no auto-summary
network 0.0.0.0
end

==================================================
R1#show ip route
Codes: C - connected, S - static, R - RIP, M - mobile, B - BGP
       D - EIGRP, EX - EIGRP external, O - OSPF, IA - OSPF inter area
       N1 - OSPF NSSA external type 1, N2 - OSPF NSSA external type 2
       E1 - OSPF external type 1, E2 - OSPF external type 2
       i - IS-IS, su - IS-IS summary, L1 - IS-IS level-1, L2 - IS-IS level-2
       ia - IS-IS inter area, * - candidate default, U - per-user static route
       o - ODR, P - periodic downloaded static route

Gateway of last resort is not set

     100.0.0.0/24 is subnetted, 5 subnets
R       100.1.34.0 [120/2] via 100.1.12.2, 00:00:14, Ethernet0/0
R       100.10.34.0 [120/3] via 100.1.12.2, 00:00:14, Ethernet0/0
C       100.10.12.0 is directly connected, Loopback0
C       100.1.12.0 is directly connected, Ethernet0/0
R       100.1.23.0 [120/1] via 100.1.12.2, 00:00:14, Ethernet0/0

*****************************************
R2#show ip route
Codes: C - connected, S - static, R - RIP, M - mobile, B - BGP
       D - EIGRP, EX - EIGRP external, O - OSPF, IA - OSPF inter area
       N1 - OSPF NSSA external type 1, N2 - OSPF NSSA external type 2
       E1 - OSPF external type 1, E2 - OSPF external type 2
       i - IS-IS, su - IS-IS summary, L1 - IS-IS level-1, L2 - IS-IS level-2
       ia - IS-IS inter area, * - candidate default, U - per-user static route
       o - ODR, P - periodic downloaded static route

Gateway of last resort is not set

     100.0.0.0/24 is subnetted, 5 subnets
R       100.1.34.0 [120/1] via 100.1.23.2, 00:00:10, Ethernet0/1
R       100.10.34.0 [120/2] via 100.1.23.2, 00:00:10, Ethernet0/1
R       100.10.12.0 [120/1] via 100.1.12.1, 00:00:10, Ethernet0/0
C       100.1.12.0 is directly connected, Ethernet0/0
C       100.1.23.0 is directly connected, Ethernet0/1
*********************************************
R3#show ip route
Codes: C - connected, S - static, R - RIP, M - mobile, B - BGP
       D - EIGRP, EX - EIGRP external, O - OSPF, IA - OSPF inter area
       N1 - OSPF NSSA external type 1, N2 - OSPF NSSA external type 2
       E1 - OSPF external type 1, E2 - OSPF external type 2
       i - IS-IS, su - IS-IS summary, L1 - IS-IS level-1, L2 - IS-IS level-2
       ia - IS-IS inter area, * - candidate default, U - per-user static route
       o - ODR, P - periodic downloaded static route

Gateway of last resort is not set

     100.0.0.0/24 is subnetted, 5 subnets
C       100.1.34.0 is directly connected, Ethernet0/0
R       100.10.34.0 [120/1] via 100.1.34.2, 00:00:24, Ethernet0/0
R       100.10.12.0 [120/2] via 100.1.23.1, 00:00:10, Ethernet0/1
R       100.1.12.0 [120/1] via 100.1.23.1, 00:00:10, Ethernet0/1
C       100.1.23.0 is directly connected, Ethernet0/1
*****************************************
R4#show ip route  
Codes: C - connected, S - static, R - RIP, M - mobile, B - BGP
       D - EIGRP, EX - EIGRP external, O - OSPF, IA - OSPF inter area
       N1 - OSPF NSSA external type 1, N2 - OSPF NSSA external type 2
       E1 - OSPF external type 1, E2 - OSPF external type 2
       i - IS-IS, su - IS-IS summary, L1 - IS-IS level-1, L2 - IS-IS level-2
       ia - IS-IS inter area, * - candidate default, U - per-user static route
       o - ODR, P - periodic downloaded static route

Gateway of last resort is not set

     100.0.0.0/24 is subnetted, 5 subnets
C       100.1.34.0 is directly connected, Ethernet0/0
C       100.10.34.0 is directly connected, Loopback0
R       100.10.12.0 [120/3] via 100.1.34.1, 00:00:26, Ethernet0/0
R       100.1.12.0 [120/2] via 100.1.34.1, 00:00:26, Ethernet0/0
R       100.1.23.0 [120/1] via 100.1.34.1, 00:00:26, Ethernet0/0

**********************
R1#ping 100.10.34.5 source 100.10.12.5

Type escape sequence to abort.
Sending 5, 100-byte ICMP Echos to 100.10.34.5, timeout is 2 seconds:
Packet sent with a source address of 100.10.12.5
!!!!!
Success rate is 100 percent (5/5), round-trip min/avg/max = 60/71/84 ms


R4#ping 100.10.12.5 source 100.10.34.5

Type escape sequence to abort.
Sending 5, 100-byte ICMP Echos to 100.10.12.5, timeout is 2 seconds:
Packet sent with a source address of 100.10.34.5
!!!!!
Success rate is 100 percent (5/5), round-trip min/avg/max = 48/78/104 ms



来自 “ ITPUB博客 ” ,链接:http://blog.itpub.net/22193071/viewspace-1370946/,如需转载,请注明出处,否则将追究法律责任。

转载于:http://blog.itpub.net/22193071/viewspace-1370946/

  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值