简单dp算法——Cow Bowling

A - Cow Bowling


Crawling in process... Crawling failed Time Limit:1000MS     Memory Limit:65536KB     64bit IO Format:%lld & %llu

Description

Input

Output

Sample Input

Sample Output

Hint

Description

The cows don't use actual bowling balls when they go bowling. They each take a number (in the range 0..99), though, and line up in a standard bowling-pin-like triangle like this:

          7 

 3   8 

 8   1   0 

 2   7   4   4 

 4   5   2   6   5
Then the other cows traverse the triangle starting from its tip and moving "down" to one of the two diagonally adjacent cows until the "bottom" row is reached. The cow's score is the sum of the numbers of the cows visited along the way. The cow with the highest score wins that frame.

Given a triangle with N (1 <= N <= 350) rows, determine the highest possible sum achievable.

Input

Line 1: A single integer, N

Lines 2..N+1: Line i+1 contains i space-separated integers that represent row i of the triangle.

Output

Line 1: The largest sum achievable using the traversal rules

Sample Input

5
7
3 8
8 1 0
2 7 4 4
4 5 2 6 5

Sample Output

30

Hint

Explanation of the sample:

          7 
         *

 3   8 
       *

 8   1   0 
       *

 2   7   4   4 
       *

 4   5   2   6   5
The highest score is achievable by traversing the cows as shown above.

解题思路:
       从倒数第二行开始,m[n-1][j] += max( m[n][j],m[n][j+1] ),依次往上选出最大的数,最后剩下m[1][1],也就是最大的那个数。

代码实现:
#include <iostream>
#include <cstdio>
#include <queue>
#include <vector>
#include <map>
#include <cmath>
#include <algorithm>
using namespace std;

int main()
{
    int n;
    cin >> n;
    long long m[400][400] = { 0 };
    int i, j;
    for( i=1; i<=n; i++ )
    {
        for( j=1; j<=i; j++ )
        {
            cin >> m[i][j];
        }
    }

    for( i=n-1; i>0; i-- )
    {
        for( j=1; j<=i; j++)
        {
            m[i][j] += max( m[i+1][j], m[i+1][j+1] );
        }
    }
    cout << m[1][1] <<endl;
    return 0;
}

评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值