zoj2913 Bus Pass BFS

ZOJ - 2913

Time Limit: 5000MS Memory Limit: 32768KB 64bit IO Format: %lld & %llu

 Status

Description

You travel a lot by bus and the costs of all the seperate tickets are starting to add up.

Therefore you want to see if it might be advantageous for you to buy a bus pass.

The way the bus system works in your country (and also in the Netherlands) is as follows:

when you buy a bus pass, you have to indicate a center zone and a star value. You are allowed to travel freely in any zone which has a distance to your center zone which is less than your star value. For example, if you have a star value of one, you can only travel in your center zone. If you have a star value of two, you can also travel in all adjacent zones, et cetera.

You have a list of all bus trips you frequently make, and would like to determine the minimum star value you need to make all these trips using your buss pass. But this is not always an easy task. For example look at the following figure:


Here you want to be able to travel from A to B and from B to D. The best center zone is 7400, for which you only need a star value of 4. Note that you do not even visit this zone on your trips!

Input

On the first line an integert(1 <=t<= 100): the number of test cases. Then for each test case:

One line with two integersnz(2 <=nz<= 9 999) andnr(1 <=nr<= 10): the number of zones and the number of bus trips, respectively.

nz lines starting with two integers idi (1 <= idi <= 9 999) and mzi (1 <= mzi <= 10), a number identifying the i-th zone and the number of zones adjacent to it, followed by mzi integers: the numbers of the adjacent zones.

nr lines starting with one integer mri (1 <= mri <= 20), indicating the number of zones the ith bus trip visits, followed by mriintegers: the numbers of the zones through which the bus passes in the order in which they are visited.

All zones are connected, either directly or via other zones.

Output

For each test case:

One line with two integers, the minimum star value and the id of a center zone which achieves this minimum star value. If there are multiple possibilities, choose the zone with the lowest number.

Sample Input

1
17 2
7400 6 7401 7402 7403 7404 7405 7406
7401 6 7412 7402 7400 7406 7410 7411
7402 5 7412 7403 7400 7401 7411
7403 6 7413 7414 7404 7400 7402 7412
7404 5 7403 7414 7415 7405 7400
7405 6 7404 7415 7407 7408 7406 7400
7406 7 7400 7405 7407 7408 7409 7410 7401
7407 4 7408 7406 7405 7415
7408 4 7409 7406 7405 7407
7409 3 7410 7406 7408
7410 4 7411 7401 7406 7409
7411 5 7416 7412 7402 7401 7410
7412 6 7416 7411 7401 7402 7403 7413
7413 3 7412 7403 7414
7414 3 7413 7403 7404
7415 3 7404 7405 7407
7416 2 7411 7412
5 7409 7408 7407 7405 7415
6 7415 7404 7414 7413 7412 7416

Sample Output

4 7400

Source

The 2007 Benelux Algorithm Programming Contest


对线路上的每个站点进行bfs,找出该站点到所有站点的最短距离,再更新线路上的站点到地图上的所有站点的的距离的最大值。

线路中的所有站点到地图上的所有站点的最大值中的最小值就是答案。

<span style="font-size:18px;">#include<iostream>
#include<cstdio>
#include<queue>
#include<cmath>
#include<cstring>
using namespace std;
const int INF=0x3f3f3f3f;
int t,nz,nr,mr,id;
int mz[10000];//相邻站点的数目
int edge[10000][15];//站的邻接表
int ans[10000];//线路上的站点到达这个站点的距离的最大值
int ID[10000];//站的号码
int ANS,ANSID;
void bfs(int v)
{
	int p;
	int c[10000];
	memset(c,INF,sizeof(c));
	c[v]=1;
	queue<int> q;
	q.push(v);
	while(!q.empty())
	{
		p=q.front();
		q.pop();
		for(int i=0;i<mz[p];i++)
		{
			if(c[edge[p][i]]>c[p]+1)
			{
				c[edge[p][i]]=c[p]+1;
				q.push(edge[p][i]);
			}
		}

	}
	for(int i=0;i<nz;i++)
	{
		ans[ID[i]]=max(c[ID[i]],ans[ID[i]]);	
	}
	/*for(int i=0;i<nz;i++)
	{
		printf("%d%   d\n",ID[i],ans[ID[i]]);
	}
	puts("_________________________");*/
}
int main()
{
	freopen("in.in","r",stdin);
	scanf("%d",&t);
	while(t--)
	{
		memset(ans,0,sizeof(ans));
		ANS=INF;
		scanf("%d%d",&nz,&nr);
		for(int i=0;i<nz;i++)
		{
			scanf("%d",&ID[i]);
			scanf("%d",&mz[ID[i]]);
			for(int j=0;j<mz[ID[i]];j++)
			{
				scanf("%d",&edge[ID[i]][j]);
			}
		}
		for(int i=0;i<nr;i++)
		{
			scanf("%d",&mr);
			for(int j=0;j<mr;j++)
			{
				scanf("%d",&id);
				bfs(id);
			}
		}
		for(int i=0;i<nz;i++)
		{
			if(ANS>ans[ID[i]])
			{
				ANS=ans[ID[i]];
				ANSID=ID[i];
			}
			else if(ANS==ans[ID[i]] && ANSID>ID[i])
			{
				ANSID=ID[i];
			}
		}
		printf("%d %d\n",ANS,ANSID);
	}
}</span>


  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
经导师精心指导并认可、获 98 分的毕业设计项目!【项目资源】:微信小程序。【项目说明】:聚焦计算机相关专业毕设及实战操练,可作课程设计与期末大作业,含全部源码,能直用于毕设,经严格调试,运行有保障!【项目服务】:有任何使用上的问题,欢迎随时与博主沟通,博主会及时解答。 经导师精心指导并认可、获 98 分的毕业设计项目!【项目资源】:微信小程序。【项目说明】:聚焦计算机相关专业毕设及实战操练,可作课程设计与期末大作业,含全部源码,能直用于毕设,经严格调试,运行有保障!【项目服务】:有任何使用上的问题,欢迎随时与博主沟通,博主会及时解答。 经导师精心指导并认可、获 98 分的毕业设计项目!【项目资源】:微信小程序。【项目说明】:聚焦计算机相关专业毕设及实战操练,可作课程设计与期末大作业,含全部源码,能直用于毕设,经严格调试,运行有保障!【项目服务】:有任何使用上的问题,欢迎随时与博主沟通,博主会及时解答。 经导师精心指导并认可、获 98 分的毕业设计项目!【项目资源】:微信小程序。【项目说明】:聚焦计算机相关专业毕设及实战操练,可作课程设计与期末大作业,含全部源码,能直用于毕设,经严格调试,运行有保障!【项目服务】:有任何使用上的问题,欢迎随时与博主沟通,博主会及时解答。
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值