China Northeast Multi-University Training Contest I

G - Non-negative Partial Sums
Time Limit:2000MS     Memory Limit:0KB     64bit IO Format:%lld & %llu

Description

Download as PDF

You are given a sequence of n numbers a0,..., an-1. A cyclic shift by k positions ( 0$ \le$k$ \le$n - 1) results in the following sequence: ak,ak+1,..., an-1a0a1,..., ak-1. How many of the n cyclic shifts satisfy the condition that the sum of the first i numbers is greater than or equal to zero for all i with 1$ \le$i$ \le$n?

Input

Each test case consists of two lines. The first contains the number n ( 1$ \le$n$ \le$106), the number of integers in the sequence. The second contains n integers a0,..., an-1 ( -1000$ \le$ai$ \le$1000) representing the sequence of numbers. The input will finish with a line containing 0.

Output

For each test case, print one line with the number of cyclic shifts of the given sequence which satisfy the condition stated above.

Sample Input

3
2 2 1
3
-1 1 1
1
-1
0

Sample Output

3
2
0

题意:给你一列数,他能够旋转,如果对于其中的一个状态,如果他的任意的前i个数之和(n>=i>=1),那么就称此状态为合法的状态,现在对于任意输入的一列数,问一共有多少个合法的状态?

思路:我们观察一下数据的范围就可以很容易的判定O(N^2)的枚举是不行的,那么我们必须找出最坏是:O(NlogN)的算法。

最终我还是没有想出好的算法,还是在同志的提醒下知道了用单调队列去解。比赛是我也想到过单调队列,但是只写过一次,因此由于掌握不熟而错过了一次很好的机会。

现在我先重申一下思路,代码改日补上:

看了一下别人的代码,我傻眼了。。。。。。。原来那么简单的题啊,但是怎么就sb了吗?

#include<iostream>
#include<cstdio>
#include<cstdlib>
using namespace std;
#define re(i,n) for(int i=0;i<n;i++)
int num[2000005];
bool hash[2000005];
int main(){
	int n ;
	while(cin>>n && n){
		for(int i=0;i<n;i++) {scanf("%d",&num[i]); hash[i] = 1;}
		for(int i=n;i<2*n;i++) num[i]= num[i-n];
		long long sum = 0;
		for(int i=n*2-1;i>=0;i--){
			if(sum<0) {sum+=num[i]; 
				if(sum<0) hash[i]=0;
			}
			else if(num[i]<0) sum=num[i], hash[i]=0;
		}
//		re(i,n) cout<<hash[i]<<" "; cout<<endl;
		int ans =0;
		for(int i=0;i<n;i++) if(hash[i]) ans ++;
		cout<<ans<<endl;
	}
}

评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值