STL有限队列的灵活运用+IO优化+区间最大最小——POJ Sliding Window


Time Limit: 12000MS Memory Limit: 65536K
Total Submissions: 24201 Accepted: 7072
Case Time Limit: 5000MS

Description

An array of size n ≤ 10 6 is given to you. There is a sliding window of size k which is moving from the very left of the array to the very right. You can only see the k numbers in the window. Each time the sliding window moves rightwards by one position. Following is an example:
The array is [1 3 -1 -3 5 3 6 7], and k is 3.
Window positionMinimum valueMaximum value
[1  3  -1] -3  5  3  6  7 -13
 1 [3  -1  -3] 5  3  6  7 -33
 1  3 [-1  -3  5] 3  6  7 -35
 1  3  -1 [-3  5  3] 6  7 -35
 1  3  -1  -3 [5  3  6] 7 36
 1  3  -1  -3  5 [3  6  7]37

Your task is to determine the maximum and minimum values in the sliding window at each position.

Input

The input consists of two lines. The first line contains two integers n and k which are the lengths of the array and the sliding window. There are n integers in the second line.

Output

There are two lines in the output. The first line gives the minimum values in the window at each position, from left to right, respectively. The second line gives the maximum values.

Sample Input

8 3
1 3 -1 -3 5 3 6 7

Sample Output

-1 -3 -3 -3 3 3
3 3 5 5 6 7

Source


/*巧妙的利用堆的排序,可以实现一个存储多种用途*/

#include <iostream>
#include<cstdio>
#include<cstring>
#include <vector>
#include <queue>
#include <limits.h>

using namespace std;


/*IO优化,提高输出的速度,需要头文件#include <limits.h>*/
void putint(int n) {
    static char buf[32];
    register int pos;
    register int x = n;
    if (x == 0) {
        putchar('0');
        return;
    }
    if (x == INT_MIN) { // x = -x do not work for the minimal value of int, so process it first
        printf("%d", x);
    }
    if (x < 0) {
        putchar('-');
        x = -x;
    }
    pos = 0;
    while (x > 0) {
        buf[pos] = x % 10 + '0';
        x /= 10;
        pos++;
    }
    pos--;
    while (pos >= 0) {
        putchar(buf[pos]);
        pos--;
    }
}

const int MAX = 1000011;
int a[MAX];

struct cmp1 {

    bool operator()(const int a1, const int a2) {
        return a[a1] > a[a2];
    }
};

struct cmp2 {

    bool operator()(const int a1, const int a2) {
        return a[a1] < a[a2];
    }
};

int main() {
    int n, m;
    while (scanf("%d%d", &n, &m) == 2) {
        for (int i = 0; i < n; i++) {
            scanf("%d", &a[i]);
        }
        priority_queue<int, vector<int>, cmp1> q1;
        priority_queue<int, vector<int>, cmp2> q2;
        for (int i = 0; i < m; i++) {
            q1.push(i);
        }
        putint(a[q1.top()]);
        for (int i = m; i < n; i++) {
            q1.push(i);
            while (i - q1.top() >= m) q1.pop();
            putchar(' ');
            putint(a[q1.top()]);
        }
        putchar('\n');

        for (int i = 0; i < m; i++) {
            q2.push(i);
        }
        putint(a[q2.top()]);
        for (int i = m; i < n; i++) {
            q2.push(i);
            while (i - q2.top() >= m) q2.pop();
            putchar(' ');
            putint(a[q2.top()]);
        }
        putchar('\n');
    }
    return 0;
}
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值