题目如下:
设计函数求一元多项式的导数。
输入格式:
以指数递降方式输入多项式非零项系数和指数(绝对值均为不超过1000的整数)。数字间以空格分隔。
输出格式:
以与输入相同的格式输出导数多项式非零项的系数和指数。数字间以空格分隔,但结尾不能有多余空格。
输入样例:
3 4 -5 2 6 1 -2 0
输出样例:
12 3 -10 1 6 0
边输入,边输出,中间还要判断一下是否输出。代码如下:
#include <iostream>
using namespace std;
int main()
{
// freopen("in.txt","r",stdin);
int a,e;
bool first=true;
while(scanf("%d %d",&a,&e)==2)
{
if(e)
{
if(!first) cout<<' ';
first=false;
printf("%d %d",a*e,e-1);
}
}
if(first) cout<<"0 0";
cout<<endl;
return 0;
}