易语言-数组的使用

.版本 2
.支持库 spec


.程序集 窗口程序集1


.子程序 __启动窗口_创建完毕
.局部变量 数组1, 文本型, , "0"
.局部变量 x, 整数型
.局部变量 y, 整数型




.' 变量循环首 (1, 3, 1, y)


    .' 变量循环首 (1, 4, 1, x)


        ' 加入成员 (数组1, “x” + 到文本 (x) + “y” + 到文本 (y))


    .' 变量循环尾 ()
.' 变量循环尾 ()
' 重定义数组 (数组1, 真, 4, 3)
' 调试输出 (数组1)






.子程序 _按钮1_被单击
.局部变量 数组, 文本型, , "2"


' 数组的使用方法
数组 [1] = “a”
数组 [2] = “b”
调试输出 (数组)




.子程序 _按钮2_被单击
.局部变量 数组, 文本型, , "2"
.局部变量 x, 整数型


.变量循环首 (1, 2, 1, x)
    数组 [x] = 到文本 (x)
.变量循环尾 ()
调试输出 (数组)




.子程序 _按钮3_被单击
.局部变量 数组, 文本型, , "2"
.局部变量 x, 整数型


.变量循环首 (1, 2, 1, x)
    .如果 (x > 1)
        数组 [x] = 到文本 (x)
    .否则
        数组 [x] = “我小于1,没人把我加入到数组”
    .如果结束


.变量循环尾 ()
调试输出 (数组)




.子程序 _按钮4_被单击
.局部变量 数组, 文本型, , "0"
.局部变量 y, 整数型
.局部变量 x, 整数型




' 加入成员 (, ) 这个函数是加入到数组的末尾,所以只要声明了数组就可以直接使用
' 4*5二维数组实例
.变量循环首 (1, 5, 1, y)
    .变量循环首 (1, 4, 1, x)
        加入成员 (数组, “x” + 到文本 (x) + “y” + 到文本 (y))
    .变量循环尾 ()
.变量循环尾 ()
' 测试数组维数
调试输出 (取数组下标 (数组, 1))
调试输出 (数组)
' 到这里为止仍然是一维数组,我们上面仅仅是把二维数组一次压入了一个一维数组,我们需要利用 数组函数改变维数
重定义数组 (数组, 真, 4, 5)  ' 假是覆盖之前的数据,我们仅仅是格式化一下数组,所以我们改为 真
调试输出 (取数组下标 (数组, 1))
调试输出 (取数组下标 (数组, 2))
调试输出 (数组)




.子程序 _按钮5_被单击
.局部变量 数组, 文本型, , "2"
.局部变量 x, 整数型
.局部变量 数组1, 文本型, , "2"


' 复制数组
.变量循环首 (1, 2, 1, x)
    .如果 (x > 1)
        数组 [x] = 到文本 (x)
    .否则
        数组 [x] = “我小于1,没人把我加入到数组”
    .如果结束


.变量循环尾 ()
调试输出 (数组)
复制数组 (数组1, 数组)
调试输出 (数组1)
展开阅读全文

没有更多推荐了,返回首页