1018

There is a public bike service in Hangzhou City which provides great convenience to the tourists from all over the world. One may rent a bike at any station and return it to any other stations in the city.

The Public Bike Management Center (PBMC) keeps monitoring the real-time capacity of all the stations. A station is said to be in perfect condition if it is exactly half-full. If a station is full or empty, PBMC will collect or send bikes to adjust the condition of that station to perfect. And more, all the stations on the way will be adjusted as well.

When a problem station is reported, PBMC will always choose the shortest path to reach that station. If there are more than one shortest path, the one that requires the least number of bikes sent from PBMC will be chosen.

Figure1

Figure 1 illustrates an example. The stations are represented by vertices and the roads correspond to the edges. The number on an edge is the time taken to reach one end station from another. The number written inside a vertex S is the current number of bikes stored at S. Given that the maximum capacity of each station is 10. To solve the problem at S3, we have 2 different shortest paths:

  1. PBMC -> S1 -> S3. In this case, 4 bikes must be sent from PBMC, because we can collect 1 bike from S1 and then take 5 bikes to S3, so that both stations will be in perfect conditions.

  2. PBMC -> S2 -> S3. This path requires the same time as path 1, but only 3 bikes sent from PBMC and hence is the one that will be chosen.

Input Specification:

Each input file contains one test case. For each case, the first line contains 4 numbers: Cmax (<= 100), always an even number, is the maximum capacity of each station; N (<= 500), the total number of stations; Sp, the index of the problem station (the stations are numbered from 1 to N, and PBMC is represented by the vertex 0); and M, the number of roads. The second line contains N non-negative numbers Ci (i=1,…N) where each Ci is the current number of bikes at Si respectively. Then M lines follow, each contains 3 numbers: Si, Sj, and Tij which describe the time Tij taken to move betwen stations Si and Sj. All the numbers in a line are separated by a space.

Output Specification:

For each test case, print your results in one line. First output the number of bikes that PBMC must send. Then after one space, output the path in the format: 0->S1->…->Sp. Finally after another space, output the number of bikes that we must take back to PBMC after the condition of Sp is adjusted to perfect.

Note that if such a path is not unique, output the one that requires minimum number of bikes that we must take back to PBMC. The judge’s data guarantee that such a path is unique.
Sample Input:

10 3 3 5
6 7 0
0 1 1
0 2 1
0 3 3
1 3 1
2 3 1

Sample Output:

3 0->2->3 0

题意:共享单车中心在某个停车点车辆数为0或者max时要出发去调整它,求最小路径,路径相等时为所带车辆最小者,路径和所带车辆都相等时为带回车辆数最小者
思路:
法一:dfs遍历每条路径:t最小?t相等,send最小?,t相等,send相等,take最小?
法二:dijkstra找出t最小(当t相等时,send最小)的所有路径,再dfs take最小的路径
坑点:不是简单的将所有沿途车点都调整为max/2,而是只有去的路上,回来的路上不调整(eg:max=10,n为3,n为8,不是take1辆车,而是send2,take3)

#include <iostream>
#include <vector>
#include <climits>

using namespace std;

int store[501] = {0};
int sta[501][501];
bool visit[501];
vector<int> path;
int cap,problem,nofs,nofr;
int send = INT_MAX;
int take = 0;
int minlen = INT_MAX;

void dfs(int node, int end, int len, vector<int> temp, int sb, int tb)
{
    if(node == end)
    {
        if(len< minlen || (len == minlen && sb < send) || (len == minlen && sb == send && tb < take))
        {
            minlen = len;
            send = sb;
            take = tb;
            path = temp;
        }
        return ;
    }
    if(len > minlen)
        return;

    for(int i=1;i<=nofs;i++)
    {
        if(visit[i] == false && sta[node][i] != INT_MAX)
        {
            visit[i] = true;
            temp.push_back(i);
            if(cap/2-tb-store[i] > 0)
            {
                dfs(i,end,len+sta[node][i],temp,sb+cap/2-tb-store[i],0);
            }
            else
            {
                dfs(i,end,len+sta[node][i],temp,sb,tb-(cap/2-store[i]));
            }
            visit[i] = false;
            temp.pop_back();
        }
    }   
}

int main()
{
    cin >> cap >> nofs >> problem >> nofr;
    for(int i=0;i<=nofs;i++)
    {
        for(int j=0;j<=nofs;j++)
        {
                sta[i][j] = INT_MAX;
        }
        visit[i] = false;
    }
    for(int i=1;i<=nofs;i++)
    {
        cin >> store[i];
    }
    for(int i=0;i<nofr;i++)
    {
        int s1,s2,t;
        scanf("%d%d%d", &s1, &s2, &t);
        sta[s1][s2] = sta[s2][s1] = t;
    }

    vector<int> R;
    dfs(0,problem,0,R,0,0);

    cout << send << " 0";
    for(int i=0;i<path.size();i++)
    {
        printf("->%d", path[i]);
    }
    cout << " " << take;

    return 0;
}
  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值