1021

A graph which is connected and acyclic can be considered a tree. The height of the tree depends on the selected root. Now you are supposed to find the root that results in a highest tree. Such a root is called the deepest root.

Input Specification:

Each input file contains one test case. For each case, the first line contains a positive integer N (<=10000) which is the number of nodes, and hence the nodes are numbered from 1 to N. Then N-1 lines follow, each describes an edge by given the two adjacent nodes’ numbers.

Output Specification:

For each test case, print each of the deepest roots in a line. If such a root is not unique, print them in increasing order of their numbers. In case that the given graph is not a tree, print “Error: K components” where K is the number of connected components in the graph.
Sample Input 1:

5
1 2
1 3
1 4
2 5

Sample Output 1:

3
4
5

Sample Input 2:

5
1 3
1 4
2 5
3 4

Sample Output 2:

Error: 2 components

题意:给出一张图,求最长路径的两端(一棵树,高度最高的结点)
思路:
用DFS求连通分量,超过1直接error,
等1时,从1结点(可以是任意一点)用DFS求得路径最长的点(都装进set里),从这些点任选一点再DFS将最长路径的点再装进去set(两者的并集),set即为所求点
不要每个点都DFS求长度,好蠢啊啊啊啊啊,再次膜拜柳婼

#include <iostream>
#include <vector>
#include <set>

using namespace std;

int n,maxhei=0;
vector<vector<int>> e;
vector<int> temp;
set<int> s;
bool visit[10001];

void DFS(int v, int height)
{
    if(height > maxhei)
    {
        temp.clear();
        temp.push_back(v);
        maxhei = height;
    }
    else if(height == maxhei)
        temp.push_back(v);

    visit[v] = true;
    for(int i=0;i<e[v].size();i++)
    {
        if(visit[e[v][i]] == false)
        {
            DFS(e[v][i], height+1);
        }
    }
}

int main()
{
    int n1,n2,cnt=0,s1;
    cin >> n;
    e.resize(n+1);
    for(int i=1;i<n;i++)
    {
        scanf("%d%d", &n1, &n2);
        e[n1].push_back(n2);
        e[n2].push_back(n1);
    }
    for(int i=1;i<=n;i++)
    {
        if(visit[i] == false)
        {
            DFS(i,1);
            if(i==1)
            {
                if(temp.size() > 0)s1=temp[0];
                for(int j=0;j<temp.size();j++)
                    s.insert(temp[j]);
            }
            cnt++;
        }
    }
    if(cnt > 1)
    {
        cout << "Error: " << cnt << " components";
    }
    else
    {
        fill(visit,visit+10001,false);
        maxhei = 0;
        temp.clear();
        DFS(s1,1);
        for(int i=0;i<temp.size();i++)
            s.insert(temp[i]); //帮我们拍排好序了,升序!!!
        for(auto it=s.begin();it!=s.end();it++)
            cout << *it << endl;
    }


    return 0;
}
  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值