1040(!)

Given a string, you are supposed to output the length of the longest symmetric sub-string. For example, given “Is PAT&TAP symmetric?”, the longest symmetric sub-string is “s PAT&TAP s”, hence you must output 11.

Input Specification:

Each input file contains one test case which gives a non-empty string of length no more than 1000.

Output Specification:

For each test case, simply print the maximum length in a line.
Sample Input:

Is PAT&TAP symmetric?

Sample Output:

11

动态规划(贪心):
dp[i][j] =1 表示从 i->j 是对称的,初始化dp[i][i]=1,顺便初始化length=2是否对称
然后从length=3->str.length()开始判断:如果dp[i+1][j-1]=1 即i+1->j-1是对称的,而且s[i] = s[j] ,则dp[i][j] = 1

#include <iostream>

using namespace std;

int dp[1010][1010];

int main()
{
    string str;
    getline(cin,str);
    int len = str.length();
    int longest=1;
    for(int i=0;i<len;i++)
    {
        dp[i][i] = 1;
        if(i<len-1 && str[i]==str[i+1])
        {
            dp[i][i+1] = 1;
            longest = 2;
        }
    }

    for(int i=3;i<=len;i++)
    {
        for(int j=0;i+j-1<len;j++)
        {
            if(str[j]== str[i+j-1] && dp[j+1][i+j-2]==1)
            {
                dp[j][i+j-1] = 1;
                longest = i;
            }
        }
    }

    cout << longest;

    return 0;
}
  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值