Another Eight Puzzle

Fill the following 8 circles with digits 1~8,with each number exactly once . Conntcted circles cannot be filled with two consecutive numbers.
There are 17 pairs of connected cicles:
A-B , A-C, A-D
B-C, B-E, B-F
C-D, C-E, C-F, C-G
D-F, D-G
E-F, E-H
F-G, F-H
G-H

Filling G with 1 and D with 2 (or G with 2 and D with 1) is illegal since G and D are connected and 1 and 2 are consecutive .However ,filling A with 8 and B with 1 is legal since 8 and 1 are not consecutive .

In this problems,some circles are already filled,your tast is to fill the remaining circles to obtain a solution (if possivle).
 

Input
The first line contains a single integer T(1≤T≤10),the number of test cases. Each test case is a single line containing 8 integers 0~8,the numbers in circle A~H.0 indicates an empty circle.

 

Output
For each test case ,print the case number and the solution in the same format as the input . if there is no solution ,print “No answer”.If there more than one solution,print “Not unique”.
 

Sample Input
3
7 3 1 4 5 8 0 0
7 0 0 0 0 0 0 0
1 0 0 0 0 0 0 0
 

Sample Output
Case 1: 7 3 1 4 5 8 6 2
Case 2: Not unique
Case 3: No answer
 


Source
ECJTU 2008 Autumn Contest
 

Recommend
#include<stdio.h>
#include<stdlib.h>
#include<math.h>  
#include<string.h>  
int a[10],vis[10],ans[10],anscnt; 
int abs(int q) 

    if(q<0) return -q; 
    return q; 

int ok() 

    if(abs(a[2]-a[1])!=1&& 
        abs(a[3]-a[1])!=1&& 
        abs(a[4]-a[1])!=1&& 
         
        abs(a[2]-a[3])!=1&& 
        abs(a[2]-a[5])!=1&& 
        abs(a[2]-a[6])!=1&& 
         
        abs(a[3]-a[4])!=1&& 
        abs(a[3]-a[5])!=1&& 
        abs(a[3]-a[6])!=1&& 
        abs(a[3]-a[7])!=1&& 
         
        abs(a[4]-a[6])!=1&& 
        abs(a[4]-a[7])!=1&& 
         
        abs(a[5]-a[6])!=1&& 
        abs(a[5]-a[8])!=1&& 
         
        abs(a[6]-a[7])!=1&& 
        abs(a[6]-a[8])!=1&& 
         
        abs(a[7]-a[8])!=1 
        ) 
        return 1; 
    else return 0; 

void DFS(int k) 

    int i,cnt=0; 
    if(k==9) 
//注意这里是k==9 而不是把让它等于8之后放在调用函数的最后面 那样的话 最后一次的赋值就会被还原为0  
        { 
            if(ok()) 
            { 
                anscnt++; 
                if(anscnt==1) 
                { 
                    for(i=1;i<=8;i++) 
                        ans[i]=a[i]; 
                } 
            } 
            return; 
        } 
    if(anscnt>=2) return; 
    if(a[k]!=0) DFS(k+1); 
    else 
        for(i=1;i<=8;i++) 
        { 
            if(!vis[i]) 
            { 
                a[k]=i; 
                vis[i]=1; 
                DFS(k+1); 
                a[k]=0; 
                vis[i]=0; 
            } 
        } 

 
int main() 

    int t,cas=0; 
    scanf("%d",&t); 
    while(t--) 
    { 
        anscnt=0; 
        int i; 
        memset(vis,0,sizeof(vis)); 
        memset(ans,0,sizeof(ans)); 
        scanf("%d %d %d %d %d %d %d %d",&a[1],&a[2],&a[3],&a[4],&a[5],&a[6],&a[7],&a[8]); 
        for(i=1;i<=8;i++) vis[a[i]]=1; 
        DFS(1); 
        printf("Case %d: ",++cas); 
        if(anscnt==1) 
        { 
            for(i=1;i<8;i++)  printf("%d ",ans[i]); 
            printf("%d\n",ans[i]); 
        } 
        else if(anscnt==0) printf("No answer\n"); 
        else printf("Not unique\n"); 
    } 
    return 0; 


  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
单词搜索迷宫(Word Search Puzzle)问题是一个经典的算法问题,其输入是一个二维的字符数组和一组单词,目标是找出字符数组网格中的所有单词。这些单词可以是水平的、垂直的或者是任意的对角线方向,所以需要查找8个不同的方向。解决这个问题的一种常见方法是使用回溯算法,具体步骤如下: 1. 遍历二维字符数组,对于每个字符,以其为起点开始搜索,搜索的方向包括水平、垂直和对角线方向。 2. 对于每个搜索到的单词,将其记录下来。 3. 重复步骤1和2,直到遍历完整个二维字符数组。 下面是一个使用C#语言实现的单词搜索迷宫算法的示例代码: ```csharp class WordSearchPuzzle { private char[,] grid; private HashSet<string> words; public WordSearchPuzzle(char[,] grid, HashSet<string> words) { this.grid = grid; this.words = words; } public void Solve() { int rows = grid.GetLength(0); int cols = grid.GetLength(1); for (int i = 0; i < rows; i++) { for (int j = 0; j < cols; j++) { Search(i, j, new StringBuilder()); } } } private void Search(int row, int col, StringBuilder sb) { if (row < 0 || row >= grid.GetLength(0) || col < 0 || col >= grid.GetLength(1)) { return; } sb.Append(grid[row, col]); string word = sb.ToString(); if (words.Contains(word)) { Console.WriteLine("Found '{0}' at [{1}, {2}] to [{3}, {4}]", word, row, col, row - sb.Length + 1, col - sb.Length + 1); } if (word.Length < 3) { Search(row + 1, col, sb); Search(row - 1, col, sb); Search(row, col + 1, sb); Search(row, col - 1, sb); Search(row + 1, col + 1, sb); Search(row - 1, col - 1, sb); Search(row + 1, col - 1, sb); Search(row - 1, col + 1, sb); } sb.Remove(sb.Length - 1, 1); } } // 使用示例 char[,] grid = new char[,] { {'t', 'h', 'i', 's'}, {'w', 'a', 't', 's'}, {'o', 'a', 'h', 'g'}, {'f', 'g', 'd', 't'} }; HashSet<string> words = new HashSet<string>() { "this", "two", "fat", "that" }; WordSearchPuzzle puzzle = new WordSearchPuzzle(grid, words); puzzle.Solve(); ```
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值