L - Common Subsequence (LCS以及回溯)

点击打开链接

A subsequence of a given sequence is the given sequence with some elements (possible none) left out. Given a sequence X = < x1, x2, ..., xm > another sequence Z = < z1, z2, ..., zk > is a subsequence of X if there exists a strictly increasing sequence < i1, i2, ..., ik > of indices of X such that for all j = 1,2,...,k, x  ij = zj. For example, Z = < a, b, f, c > is a subsequence of X = < a, b, c, f, b, c > with index sequence < 1, 2, 4, 6 >. Given two sequences X and Y the problem is to find the length of the maximum-length common subsequence of X and Y.
Input
The program input is from the std input. Each data set in the input contains two strings representing the given sequences. The sequences are separated by any number of white spaces. The input data are correct.
Output
For each set of data the program prints on the standard output the length of the maximum-length common subsequence from the beginning of a separate line.
Sample Input
abcfbc         abfcab
programming    contest 
abcd           mnp
Sample Output
4
2
0

题解:要注意子串与子序列的区别,子串是连续的一段,而子序列则可以不连续如:

            aslkdjf 中子串可以为aslk,而子序列可以表示为a k d f。

             用二维数组dp[i][j]进行表示,i代表字符串a中的一个字符,j代表字符串b中的一个字符,若两者相同,则dp[i][j]=dp[i-1][j-1]+1;若否则dp[i][j]=max(dp[i-1][j],dp[i][j-1])

             可得

具体代码:

#include<cstdio>
#include<cstring>
#include<algorithm>
#include<stack>
using namespace std;
int dp[1005][1005];
int main()
{
	char a[1004],b[1004];
	while(scanf("%s %s",a+1,b+1)!=EOF)//a+1代表输入的字符从第二个位置开始 
	{
		memset(dp,0,sizeof(dp));
		a[0]=b[0]='0'; 
		int i=strlen(a)-1;
		int j=strlen(b)-1;
		for(int r=1;r<=i;r++)
		{
			for(int t=1;t<=j;t++)
			{
				if(a[r]==b[t])
				dp[r][t]=dp[r-1][t-1]+1;
				else
				dp[r][t]=max(dp[r-1][t],dp[r][t-1]);
			} 
		}
		printf("%d\n",dp[i][j]);
	}
	
return 0; 
}
拓展:

若要根据其子序列的长度寻求其子序列的组成,具体看下图:



#include<cstdio>
#include<cstring>
#include<algorithm>
#include<stack>
using namespace std;
int dp[1005][1005];
int main()
{
	char a[1004],b[1004];
	while(scanf("%s %s",a+1,b+1)!=EOF)//a+1代表输入的字符从第二个位置开始 
	{
		memset(dp,0,sizeof(dp));
		a[0]=b[0]='0'; 
		int i=strlen(a)-1;
		int j=strlen(b)-1;
		for(int r=1;r<=i;r++)
		{
			for(int t=1;t<=j;t++)
			{
				if(a[r]==b[t])
				dp[r][t]=dp[r-1][t-1]+1;
				else
				dp[r][t]=max(dp[r-1][t],dp[r][t-1]);
			} 
		}
		int l1=i;
		int l2=j;
		stack<char > s;//定义一个栈,先进后出 
		while(l1>0&&l2>0)//判断是否有一个字符串首先比较完毕 
		{
			if(a[l1]==b[l2])//如果字符相同,则入栈且坐标各向左上方移动一位 
			{
				s.push(a[l1]);
				l1--;l2--;
			}
			else if(dp[l1-1][l2]>dp[l1][l2-1])//如果不同,且其左边的数大于上边的数,向上移动一位 
			l1--;
			else//否则向左移动一位 
			l2--;
		}
		while(!s.empty())
		{
			char x;
			x=s.top();s.pop();
			printf("%c",x);
			if(!s.size())
			printf("\n");
			
		}	
		printf("%d\n",dp[i][j]);
	}
	
return 0; 
}
 




  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值