Insert or Merge

According to Wikipedia:

Insertion sort iterates, consuming one input element each repetition, and growing a sorted output list. Each iteration, insertion sort removes one element from the input data, finds the location it belongs within the sorted list, and inserts it there. It repeats until no input elements remain.

Merge sort works as follows: Divide the unsorted list into N sublists, each containing 1 element (a list of 1 element is considered sorted). Then repeatedly merge two adjacent sublists to produce new sorted sublists until there is only 1 sublist remaining.

Now given the initial sequence of integers, together with a sequence which is a result of several iterations of some sorting method, can you tell which sorting method we are using?

Input Specification:

Each input file contains one test case. For each case, the first line gives a positive integer N (). Then in the next line, N integers are given as the initial sequence. The last line contains the partially sorted sequence of the N numbers. It is assumed that the target sequence is always ascending. All the numbers in a line are separated by a space.

Output Specification:

For each test case, print in the first line either "Insertion Sort" or "Merge Sort" to indicate the method used to obtain the partial result. Then run this method for one more iteration and output in the second line the resuling sequence. It is guaranteed that the answer is unique for each test case. All the numbers in a line must be separated by a space, and there must be no extra space at the end of the line.

Sample Input 1:

10
3 1 2 8 7 5 9 4 6 0
1 2 3 7 8 5 9 4 6 0

Sample Output 1:

Insertion Sort
1 2 3 5 7 8 9 4 6 0

Sample Input 2:

10
3 1 2 8 7 5 9 4 0 6
1 3 2 8 5 7 4 9 0 6

Sample Output 2:          

Merge Sort

1 2 3 8 4 5 7 9 0 6 

#include<iostream>
using namespace std;

int f1[105];
int f2[105];
int f3[105];
void Print(int a[],int len)
{
	cout<<a[0];
	for(int i=1;i<len;i++)
	{
		cout<<" "<<a[i];
	}
	cout<<endl;
}

bool Check(int a[],int b[],int len)
{
	for(int i=0;i<len;i++)
	{
		if(a[i]!=b[i])
			return false;
	}
	
	return true;
}


void Merge(int a[],int l,int r,int rend)
{
	int temp[rend-l+1];
	int lend=r-1;
	int i=l,j=r,k=0;
	while(i<=lend&&j<=rend)
	{
		if(a[i]<a[j])
			temp[k++]=a[i++];
		else
			temp[k++]=a[j++];
	}
	
	while(i<=lend)
	{
		temp[k++]=a[i++];
	}
	
	while(j<=rend)
	{
		temp[k++]=a[j++];
	}
	
	for(i=l,k=0;i<=rend;i++)
	{
		a[i]=temp[k++];
	}
}

bool Insert_Sort(int a[],int b[],int N)
{
    bool isInsert = false;
    for ( int i = 1 ; i < N ; i++){
        int tmp = a[i];
        int j;
        for (j = i ; j > 0 && a[j-1] > tmp ; j--){
            a[j] = a[j-1];
        }
        a[j] = tmp;
        if (isInsert){
            cout<<"Insertion Sort"<<endl;
            Print(a,N);
            break;
        }else if(Check(a,b,N)){
            isInsert = true;    
        }
    }
    return isInsert;
}


bool Merge_Sort(int a[],int b[],int len)
{
	bool flag=false;
	
	for(int i=1;i<len;i=i*2)
	{
		for(int j=0;j<len;j=j+2*i)
		{
		//	cout<<i<<endl<<endl;
			if(j+2*i-1<=len-1)
			{
				Merge(a,j,j+i,j+i*2-1);
			//	cout<<"!";
			//	Print(a,len);
			}
			else
				if(j+i-1<len-1)
				{
					Merge(a,j,j+i,len-1);
				//	cout<<"!!";
				//	Print(a,len);	
				}
		}
		
		if(flag)
		{
			cout<<"Merge Sort"<<endl;
			Print(a,len);
			break;
		}
		else
			if(Check(a,b,len))
			{
				flag=true;
			}
		
	}
		
	return flag;
	
}

int main()
{
	int len;
	cin>>len;
	
	for(int i=0;i<len;i++)
	{
		cin>>f1[i];
		f3[i]=f1[i];
	}
	
	for(int i=0;i<len;i++)
	{
		cin>>f2[i];
	}
	bool flag;
	flag=Merge_Sort(f1,f2,len);
	
    if (flag){
        return 0;
    }else{
        bool isInsert = Insert_Sort(f3,f2,len);
        return 0;
    }
	return 0;
}

  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值