09-排序2 Insert or Merge (25 分)-------C语言

According to Wikipedia:

Insertion sort iterates, consuming one input element each repetition, and growing a sorted output list. Each iteration, insertion sort removes one element from the input data, finds the location it belongs within the sorted list, and inserts it there. It repeats until no input elements remain.

Merge sort works as follows: Divide the unsorted list into N sublists, each containing 1 element (a list of 1 element is considered sorted). Then repeatedly merge two adjacent sublists to produce new sorted sublists until there is only 1 sublist remaining.

Now given the initial sequence of integers, together with a sequence which is a result of several iterations of some sorting method, can you tell which sorting method we are using?

Input Specification:

Each input file contains one test case. For each case, the first line gives a positive integer N (≤100). Then in the next line, N integers are given as the initial sequence. The last line contains the partially sorted sequence of the N numbers. It is assumed that the target sequence is always ascending. All the numbers in a line are separated by a space.

Output Specification:

For each test case, print in the first line either "Insertion Sort" or "Merge Sort" to indicate the method used to obtain the partial result. Then run this method for one more iteration and output in the second line the resuling sequence. It is guaranteed that the answer is unique for each test case. All the numbers in a line must be separated by a space, and there must be no extra space at the end of the line.

Sample Input 1:

10
3 1 2 8 7 5 9 4 6 0
1 2 3 7 8 5 9 4 6 0

结尾无空行

Sample Output 1:

Insertion Sort
1 2 3 5 7 8 9 4 6 0

结尾无空行

Sample Input 2:

10
3 1 2 8 7 5 9 4 0 6
1 3 2 8 5 7 4 9 0 6

结尾无空行

Sample Output 2:

Merge Sort
1 2 3 8 4 5 7 9 0 6

        这题的思路是:我写好插入排序和归并排序算法后,每排序一步我就比较一下,得到的数组一不一样,如果一样了,ok我就直接输入就好了。

        另外,我这过程中有很多重复性语句,看着有点傻.......大家其实可以改成函数,看着舒服点

//09-排序2 Insert or Merge (25 分)
#include<stdio.h>
#include<stdlib.h>
int N;
int compare(int A[], int last[]);
void Insert_Sort(int pre[], int last[]);
void Merge_Sort(int pre[], int last[]);
void Merge(int A[], int TmpA[], int L, int R, int RightEnd);
void Merge_Pass(int A[], int TmpA[], int length);

int main()
{
    scanf("%d", &N);
    int i, pre[N], last[N];
    for(i=0;i<N;i++){
        scanf("%d", &pre[i]);
    }
    for(i=0;i<N;i++){
        scanf("%d", &last[i]);
    }
    Insert_Sort(pre, last);
    Merge_Sort(pre, last);
    
    return 0;
}

int compare(int A[], int last[])
{
    int flag = 1;
    for(int i=0;i<N;i++){
        if(A[i]!=last[i]){
            flag = 0;
            break;
        }
    }
    return flag;
}

void Insert_Sort(int pre[], int last[])
{
    int A[N], i, flag = 0, P;
    for(i=0;i<N;i++){
        A[i] = pre[i];
    }
    for(P=1;P<N;P++){
        int temp = A[P]; 
        for(i=P;i>0 && A[i-1]>temp;i--){
            A[i] = A[i-1];
        }
        A[i] = temp;
        if(compare(A, last)){
            printf("Insertion Sort\n");
            flag=1;
            continue;
        }
        if(flag==1){
            for(i=0;i<N;i++){
                printf("%d", A[i]);
                if(i!=N-1) printf(" ");
            }
            break; 
        }
    }
}

void Merge_Sort(int pre[], int last[])
{
    int A[N], i, j, flag = 0;
    for(i=0;i<N;i++){
        A[i] = pre[i];
    }
    
    int* TmpA = (int*) malloc (N*sizeof(int));
    int length = 1;
    if(TmpA!=NULL){
        while(length<N){
            Merge_Pass(A, TmpA, length);
            length*=2;
            if(flag==1){
                for(i=0;i<N;i++){
                    printf("%d", A[i]);
                    if(i!=N-1) printf(" ");
                }
                break; 
            }
            if(compare(A, last)){
                printf("Merge Sort\n");
                flag=1;
            }
            Merge_Pass(TmpA, A, length);
            length*=2;
            if(flag==1){
                for(i=0;i<N;i++){
                    printf("%d", A[i]);
                    if(i!=N-1) printf(" ");
                }
                break; 
            }
            if(compare(A, last)){
                printf("Merge Sort\n");
                flag=1;
            }
        }
        free(TmpA);
    }
    else printf("空间不足");
}

void Merge(int A[], int TmpA[], int L, int R, int RightEnd)
{
    int LeftEnd = R-1;
    int number = RightEnd - L + 1;
    int tmp = L, i;
    while(L<=LeftEnd && R<=RightEnd){
        if(A[L] <A[R]) TmpA[tmp++] = A[L++];
        else TmpA[tmp++] = A[R++];
    }
    while(L<=LeftEnd) TmpA[tmp++] = A[L++];
    while(R<=RightEnd) TmpA[tmp++] = A[R++];
    for(i=0;i<number;i++,RightEnd--){
         A[RightEnd] = TmpA[RightEnd];
    }
}

void Merge_Pass(int A[], int TmpA[], int length)
{
    int i, j;
    for(i=0;i<=N-2*length;i+=2*length){
        Merge(A, TmpA, i, i+length, i+2*length-1);
    }
    if(i+length<N) Merge(A, TmpA, i, i+length, N-1);
    else for(j=1;j<N;j++) TmpA[j] = A[j];
}

  • 1
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值