vue项目中浏览器兼容问题

vue 专栏收录该内容
10 篇文章 0 订阅

vue项目中浏览器兼容问题

1.安装

npm install --save babel-polyfill 
npm install es6-promise --save

2.在main.js中引入(最好放在最前面)

import 'babel-polyfill'
import promise from 'es6-promise'
promise.polyfill()

3.在webpack.base.conf.js中配置

module.exports = {
  ......
  entry: {
    app: ["babel-polyfill", "./src/main.js"],
  },
  ......
  }

4.在index.html中强制浏览器默认渲染最高版本内核

<meta http-equiv="X-UA-Compatible" content="IE=edge,chrome=1"/>
  • 0
    点赞
  • 0
    评论
  • 15
    收藏
  • 一键三连
    一键三连
  • 扫一扫,分享海报

©️2021 CSDN 皮肤主题: 大白 设计师:CSDN官方博客 返回首页
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、C币套餐、付费专栏及课程。

余额充值