Goldbach's conjecture is one of the oldest unsolved problems in number theory and in all of mathematics. It states:
Every even integer, greater than 2, can be expressed as the sum of two primes [1].
Now your task is to check whether this conjecture holds for integers up to 107.
Input
Input starts with an integer T (≤ 300), denoting the number of test cases.
Each case starts with a line containing an integer n (4 ≤ n ≤ 107, n is even).
Output
For each case, print the case number and the number of ways you can express n as sum of two primes. To be more specific, we want to find the number of (a, b) where
1) Both a and b are prime
2) a + b = n
3) a ≤ b
Sample Input
2
6
4
Sample Output
Case 1: 1
Case 2: 1
Note
1. An integer is said to be prime, if it is divisible by exactly two different integers. First few primes are 2, 3, 5, 7, 11, 13, ...
这个题一看就是一个素数问题,然后枚举就可以,但是提交错了好几次,试了试边界10000000,编译器报错,提示下标超界,把max改成了20000005就对了
import java.util.Arrays;
import java.util.Scanner;
public class Main {
static final int max=20000005;
static boolean vis[]=new boolean[max];
static int prime[]=new int[2000005];
public static void is_Prime(){
Arrays.fill(vis, true);
vis[0]=vis[1]=false;
int k=0;
for(int i=2;i<max;i++){//可不能等于,要不然等于max就数组越界了
if(vis[i])
prime[k++]=i;
for(int j=0;j<k&&i*prime[j]<max;j++){
vis[i*prime[j]]=false;
if(i%prime[j]==0){
break;
}
}
}
//System.out.println(k);
//System.out.println(prime[k-1 ]);
}
public static void main(String[] args) {
is_Prime();
Scanner scan=new Scanner(System.in);
int t=scan.nextInt();
int n=0;
int k=1;
while(t!=0){
n=scan.nextInt();
System.out.print("Case "+k+": ");
long cnt=0;
for(int i=0;prime[i]<n;i++){
if(vis[n-prime[i]]&&prime[i]<=n-prime[i]){
cnt++;
}
}
System.out.println(cnt);
t--;
k++;
}
}
}