A box contains black balls and a single red ball. Alice and Bob draw balls from this box without replacement, alternating after each draws until the red ball is drawn. The game is won by the player who happens to draw the single red ball. Bob is a gentleman and offers Alice the choice of whether she wants to start or not. Alice has a hunch that she might be better off if she starts; after all, she might succeed in the first draw. On the other hand, if her first draw yields a black ball, then Bob’s chances to draw the red ball in his first draw are increased, because then one black ball is already removed from the box. How should Alice decide in order to maximize her probability of winning? Help Alice with decision.
Input
Multiple test cases (number of test cases≤50), process till end of input.
For each case, a positive integer k (1≤k≤10^5) is given on a single line.
Output
For each case, output:
1, if the player who starts drawing has an advantage
2, if the player who starts drawing has a disadvantage
0, if Alice's and Bob's chances are equal, no matter who starts drawing
on a single line.
Sample Input
1 2
Sample Output
0 1
题意:k个黑球和1个红球,先抽到红球赢,问先手赢得概率大还是后手大,还是一样大
思路:第n个回合抽到红球的概率一定是1/(k+1),那么赢得概率等于拥有的回合数*1/(k+1)
如果k为奇数,两边的回合一样,所以概率一样大;如果为偶数,先手多一个回合的机会,所以先手的概率大
import java.util.Scanner;
public class Main {
public static void main(String[] args) {
Scanner scan=new Scanner(System.in);
while(scan.hasNext()){
int k=scan.nextInt();
if(k%2==0){
System.out.println("1");
}
else{
System.out.println("0");
}
}
}
}