hdu5978 To begin or not to begin(概率)

A box contains black balls and a single red ball. Alice and Bob draw balls from this box without replacement, alternating after each draws until the red ball is drawn. The game is won by the player who happens to draw the single red ball. Bob is a gentleman and offers Alice the choice of whether she wants to start or not. Alice has a hunch that she might be better off if she starts; after all, she might succeed in the first draw. On the other hand, if her first draw yields a black ball, then Bob’s chances to draw the red ball in his first draw are increased, because then one black ball is already removed from the box. How should Alice decide in order to maximize her probability of winning? Help Alice with decision.

Input

Multiple test cases (number of test cases≤50), process till end of input. 
For each case, a positive integer k (1≤k≤10^5) is given on a single line. 

Output

For each case, output: 
1, if the player who starts drawing has an advantage 
2, if the player who starts drawing has a disadvantage 
0, if Alice's and Bob's chances are equal, no matter who starts drawing 
on a single line. 

Sample Input

1
2

Sample Output

0
1

题意:k个黑球和1个红球,先抽到红球赢,问先手赢得概率大还是后手大,还是一样大

思路:第n个回合抽到红球的概率一定是1/(k+1),那么赢得概率等于拥有的回合数*1/(k+1)

          如果k为奇数,两边的回合一样,所以概率一样大;如果为偶数,先手多一个回合的机会,所以先手的概率大

  

import java.util.Scanner;

public class Main {
   public static void main(String[] args) {
	  Scanner scan=new Scanner(System.in);
	  while(scan.hasNext()){
		  int k=scan.nextInt();
		  if(k%2==0){
			  System.out.println("1");
		  }
		  else{
			  System.out.println("0");
		  }
	  }
}
}

 

评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包

打赏作者

小鱼爱吃火锅

你的鼓励将是我创作的最大动力

¥1 ¥2 ¥4 ¥6 ¥10 ¥20
扫码支付:¥1
获取中
扫码支付

您的余额不足,请更换扫码支付或充值

打赏作者

实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值