hdu6186 CS Course (维护前缀和和后缀和)

Little A has come to college and majored in Computer and Science. 

Today he has learned bit-operations in Algorithm Lessons, and he got a problem as homework. 

Here is the problem: 

You are giving n non-negative integers a1,a2,⋯,ana1,a2,⋯,an, and some queries. 

A query only contains a positive integer p, which means you 
are asked to answer the result of bit-operations (and, or, xor) of all the integers except apap. 

Input

There are no more than 15 test cases. 

Each test case begins with two positive integers n and p 
in a line, indicate the number of positive integers and the number of queries. 

2≤n,q≤1052≤n,q≤105 

Then n non-negative integers a1,a2,⋯,ana1,a2,⋯,an follows in a line, 0≤ai≤1090≤ai≤109 for each i in range[1,n]. 

After that there are q positive integers p1,p2,⋯,pqp1,p2,⋯,pqin q lines, 1≤pi≤n1≤pi≤n for each i in range[1,q].

Output

For each query p, output three non-negative integers indicates the result of bit-operations(and, or, xor) of all non-negative integers except apap in a line. 

Sample Input

3 3
1 1 1
1
2
3

Sample Output

1 1 0
1 1 0
1 1 0

代码: 


import java.util.Scanner;

public class main21 {
   public static void main(String[] args) {
	    final int max=100005;
	    int a[]=new int[max];
	    int sa[]=new int[max];
	    int sb[]=new int[max];
	    int sc[]=new int[max];
	    int ea[]=new int[max];
	    int eb[]=new int[max];
	    int ec[]=new int[max];
	    Scanner scan=new Scanner(System.in);
        while(scan.hasNext()){
        	int n=scan.nextInt();
    	    int q=scan.nextInt();
	        for(int i=1;i<=n;i++){
	    	   a[i]=scan.nextInt();
	        }
	        sa[1]=sb[1]=sc[1]=a[1];
	        for(int i=2;i<=n;i++){
	        	sa[i]=sa[i-1]&a[i];
	        	sb[i]=sb[i-1]|a[i];
	        	sc[i]=sc[i-1]^a[i];
	        }
	        ea[n]=eb[n]=ec[n]=a[n];
	        for(int i=n-1;i>0;i--){
	        	ea[i]=ea[i+1]&a[i];
	        	eb[i]=eb[i+1]|a[i];
	        	ec[i]=ec[i+1]^a[i];
	        }
	        while(q>0){
	        	int p=scan.nextInt();
	        	if(p==1){
	        		System.out.println(ea[2]+" "+eb[2]+" "+ec[2]);
	        	}
	        	else if(p==n){
	        		System.out.println(sa[n-1]+" "+sb[n-1]+" "+sc[n-1]);
	        	}
	        	else{
	        		System.out.println((sa[p-1]&ea[p+1])+" "+(sb[p-1]|eb[p+1])+" "+(sc[p-1]^ec[p+1]));
	        	}
	        	q--;
	        }
        }
}
}

 

  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 打赏
    打赏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包

打赏作者

OUC_lkc

你的鼓励将是我创作的最大动力

¥1 ¥2 ¥4 ¥6 ¥10 ¥20
扫码支付:¥1
获取中
扫码支付

您的余额不足,请更换扫码支付或充值

打赏作者

实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值