HDU1159 Common Subsequence(最长公共子序列--模板题)

Common Subsequence

Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 65536/32768 K (Java/Others)
Total Submission(s): 55840    Accepted Submission(s): 25811


 

Problem Description

A subsequence of a given sequence is the given sequence with some elements (possible none) left out. Given a sequence X = <x1, x2, ..., xm> another sequence Z = <z1, z2, ..., zk> is a subsequence of X if there exists a strictly increasing sequence <i1, i2, ..., ik> of indices of X such that for all j = 1,2,...,k, xij = zj. For example, Z = <a, b, f, c> is a subsequence of X = <a, b, c, f, b, c> with index sequence <1, 2, 4, 6>. Given two sequences X and Y the problem is to find the length of the maximum-length common subsequence of X and Y.
The program input is from a text file. Each data set in the file contains two strings representing the given sequences. The sequences are separated by any number of white spaces. The input data are correct. For each set of data the program prints on the standard output the length of the maximum-length common subsequence from the beginning of a separate line.

 

 

Sample Input

 

abcfbc abfcab programming contest abcd mnp

 

 

Sample Output

 

4 2 0

 

LCS模板题,dp实现

import java.util.Arrays;
import java.util.Scanner;

public class main1159 {
	static final int max=1005;
	public static int LCS(String a,String b){
		 int dp[][]=new int[1005][1005];
		 for(int i=0;i<max;i++)
			 Arrays.fill(dp[i], 0);
		 for(int i=1;i<=a.length();i++)
			 for(int j=1;j<=b.length();j++){
				 if(a.charAt(i-1)==b.charAt(j-1)){
					 dp[i][j]=dp[i-1][j-1]+1;
				 }
				 else{
					 dp[i][j]=Math.max(dp[i-1][j], dp[i][j-1]);
				 }
			 }
		 return dp[a.length()][b.length()];
	}
      public static void main(String[] args) {
		 Scanner scan=new Scanner(System.in);
		 while(scan.hasNext()){
			 String a=scan.next();
			 String b=scan.next();
			 int cnt=LCS(a,b);
			 System.out.println(cnt);
		 }
	}
}

 

  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 打赏
    打赏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包

打赏作者

ksuper&

你的鼓励将是我创作的最大动力

¥1 ¥2 ¥4 ¥6 ¥10 ¥20
扫码支付:¥1
获取中
扫码支付

您的余额不足,请更换扫码支付或充值

打赏作者

实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值