Balanced Lineup (线段树--区间查询最大值和最小值)

For the daily milking, Farmer John's N cows (1 ≤ N ≤ 50,000) always line up in the same order. One day Farmer John decides to organize a game of Ultimate Frisbee with some of the cows. To keep things simple, he will take a contiguous range of cows from the milking lineup to play the game. However, for all the cows to have fun they should not differ too much in height.

Farmer John has made a list of Q (1 ≤ Q ≤ 200,000) potential groups of cows and their heights (1 ≤ height ≤ 1,000,000). For each group, he wants your help to determine the difference in height between the shortest and the tallest cow in the group.

Input

Line 1: Two space-separated integers, N and Q
Lines 2.. N+1: Line i+1 contains a single integer that is the height of cow i 
Lines N+2.. NQ+1: Two integers A and B (1 ≤ A ≤ B ≤ N), representing the range of cows from A to B inclusive.

Output

Lines 1.. Q: Each line contains a single integer that is a response to a reply and indicates the difference in height between the tallest and shortest cow in the range.

Sample Input

6 3
1
7
3
4
2
5
1 5
4 6
2 2

Sample Output

6

题意:n头牛,m次查询,每次求出区间[a,b]的最大值与最小值的差

java输入自己写,否则超时

import java.io.BufferedReader;
import java.io.InputStreamReader;
import java.math.BigDecimal;
import java.math.BigInteger;
import java.util.Scanner;
import java.util.StringTokenizer;

class InputReader
{
    BufferedReader buf;
    StringTokenizer tok;
    InputReader()
    {
        buf = new BufferedReader(new InputStreamReader(System.in));
    }
    boolean hasNext()
    {
        while(tok == null || !tok.hasMoreElements()) 
        {
            try
            {
                tok = new StringTokenizer(buf.readLine());
            } 
            catch(Exception e) 
            {
                return false;
            }
        }
        return true;
    }
    String next()
    {
        if(hasNext()) return tok.nextToken();
        return null;
    }
    int nextInt()
    {
        return Integer.parseInt(next());
    }
    long nextLong()
    {
        return Long.parseLong(next());
    }
    double nextDouble()
    {
        return Double.parseDouble(next());
    }
    BigInteger nextBigInteger()
    {
        return new BigInteger(next());
    }
    BigDecimal nextBigDecimal()
    {
        return new BigDecimal(next());
    }
}

public class Main{
	static int n,q;
	static final int MAX=50005;
	static int max[]=new int[MAX<<2];
	static int min[]=new int[MAX<<2];
	static int arr[]=new int[MAX<<2];
	public static void build(int node,int l,int r){
		 if(l==r){
			 max[node]=arr[r];
			 min[node]=arr[r];
			 return;
		 }
		 int mid=(l+r)/2;
		 build(node<<1,l,mid);
		 build(node<<1|1,mid+1,r);
		 max[node]=Math.max(max[node<<1], max[node<<1|1]);
		 min[node]=Math.min(min[node<<1], min[node<<1|1]);
	}
	public static int queryMax(int node,int l,int r,int a,int b){
		 if(l>=a&&r<=b){
			 return max[node];
		 }
		 int mid=(l+r)/2;
		 if(b<=mid) return queryMax(node<<1,l,mid,a,b);
		 else if(a>mid) return queryMax(node<<1|1,mid+1,r,a,b);
		 else return Math.max(queryMax(node<<1,l,mid,a,b), queryMax(node<<1|1,mid+1,r,a,b));
	}
	public static int queryMin(int node,int l,int r,int a,int b){
		 if(l>=a&&r<=b){
			 return min[node];
		 }
		 int mid=(l+r)/2;
		 if(b<=mid) return queryMin(node<<1,l,mid,a,b);
		 else if(a>mid) return queryMin(node<<1|1,mid+1,r,a,b);
		 else return Math.min(queryMin(node<<1,l,mid,a,b), queryMin(node<<1|1,mid+1,r,a,b));
	}
    public static void main(String[] args) {
    	InputReader scan=new InputReader();
		 n=scan.nextInt();
		 q=scan.nextInt();
		 for(int i=1;i<=n;i++)
			 arr[i]=scan.nextInt();
		 build(1,1,n);
		 while(q!=0){
			 int a=scan.nextInt();
			 int b=scan.nextInt();
			 int maxx=queryMax(1,1,n,a,b);
			 int minn=queryMin(1,1,n,a,b);
			 System.out.println(maxx-minn);
			 q--;
		 }
	}
}

 

  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 打赏
    打赏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包

打赏作者

ksuper&

你的鼓励将是我创作的最大动力

¥1 ¥2 ¥4 ¥6 ¥10 ¥20
扫码支付:¥1
获取中
扫码支付

您的余额不足,请更换扫码支付或充值

打赏作者

实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值