Frogger (最短路变形-求最短路上的最大权)

Freddy Frog is sitting on a stone in the middle of a lake. Suddenly he notices Fiona Frog who is sitting on another stone. He plans to visit her, but since the water is dirty and full of tourists' sunscreen, he wants to avoid swimming and instead reach her by jumping. 
Unfortunately Fiona's stone is out of his jump range. Therefore Freddy considers to use other stones as intermediate stops and reach her by a sequence of several small jumps. 
To execute a given sequence of jumps, a frog's jump range obviously must be at least as long as the longest jump occuring in the sequence. 
The frog distance (humans also call it minimax distance) between two stones therefore is defined as the minimum necessary jump range over all possible paths between the two stones. 

You are given the coordinates of Freddy's stone, Fiona's stone and all other stones in the lake. Your job is to compute the frog distance between Freddy's and Fiona's stone. 

Input

The input will contain one or more test cases. The first line of each test case will contain the number of stones n (2<=n<=200). The next n lines each contain two integers xi,yi (0 <= xi,yi <= 1000) representing the coordinates of stone #i. Stone #1 is Freddy's stone, stone #2 is Fiona's stone, the other n-2 stones are unoccupied. There's a blank line following each test case. Input is terminated by a value of zero (0) for n.

Output

For each test case, print a line saying "Scenario #x" and a line saying "Frog Distance = y" where x is replaced by the test case number (they are numbered from 1) and y is replaced by the appropriate real number, printed to three decimals. Put a blank line after each test case, even after the last one.

Sample Input

2
0 0
3 4

3
17 4
19 4
18 5

0

Sample Output

Scenario #1
Frog Distance = 5.000

Scenario #2
Frog Distance = 1.414

题意:求青蛙距离,青蛙距离(人类也称其为最小最大距离)在两块石头之间,因此被定义为两块石头之间所有可能的路径之间的最小必要跳跃范围,就是最短路上 的最大权是多少

核心:用dis[i]存从1->2的最短路径的每段路径的长度,通过每一步的比较求出最大权

注意:这是无向图,因为你wrong了好几次

代码:

#include<iostream>
#include<cstring>
#include<cmath>
#include<cstdio>
using namespace std;
#define Inf 0x3f3f3f3f
const int N=205;
struct node{
	int x,y;
}point[N];
double g[N][N];
double dis[N]; 
bool vis[N];
int n;
double Dijkstra()
{
	memset(vis,0,sizeof(vis));
	for(int i=1;i<=n;i++)
	   dis[i]=g[1][i];
	vis[1]=1;
	double Max=0;
	for(int j=1;j<n;j ++)
	{
	   	double minn=Inf;
		int u;
	   	for(int i=1;i<=n;i++)
	   	{
	   	   if(!vis[i]&&dis[i]<minn)	
	   	    {
	   	   	    u=i;
			    minn=dis[i]; 
			}
		}
		if(Max<minn) Max=minn;
		if(u==2) return Max; 
		vis[u]=1;
		for(int i=1;i<=n;i++)
		{
			if(!vis[i]&&dis[i]>g[u][i])//用dis[i]存从1->2的最短路径的每段路径的长度
			    dis[i]=g[u][i];
		}
	} 
}
int main()
{
	int k=1;
	while(scanf("%d",&n)!=EOF)
	{
		if(n==0) break;
		for(int i=1;i<=n;i++)
		{
			cin>>point[i].x>>point[i].y;
	    }
	    memset(g,Inf,sizeof(g));
	    for(int i=1;i<=n;i++)
	          g[i][i]=0;
	    for(int i=1;i<=n;i++)  
	       for(int j=i+1;j<=n;j++)
	       {
	       	    double t_x=(point[i].x-point[j].x)*(point[i].x-point[j].x);
	       	    double t_y=(point[i].y-point[j].y)*(point[i].y-point[j].y);
	       	    g[i][j]=g[j][i]=sqrt(t_x+t_y);//双向可通 
		   }
		printf("Scenario #%d\n",k++);
		printf("Frog Distance = %.3f\n\n",Dijkstra());
	}
	return 0;
}

 

  • 0
    点赞
  • 1
    收藏
    觉得还不错? 一键收藏
  • 打赏
    打赏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包

打赏作者

ksuper&

你的鼓励将是我创作的最大动力

¥1 ¥2 ¥4 ¥6 ¥10 ¥20
扫码支付:¥1
获取中
扫码支付

您的余额不足,请更换扫码支付或充值

打赏作者

实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值