Poj 2386 Lake Counting 题解

Lake Counting
Time Limit: 1000MS Memory Limit: 65536K
Total Submissions: 30372 Accepted: 15176

Description

Due to recent rains, water has pooled in various places in Farmer John's field, which is represented by a rectangle of N x M (1 <= N <= 100; 1 <= M <= 100) squares. Each square contains either water ('W') or dry land ('.'). Farmer John would like to figure out how many ponds have formed in his field. A pond is a connected set of squares with water in them, where a square is considered adjacent to all eight of its neighbors. 

Given a diagram of Farmer John's field, determine how many ponds he has.

Input

* Line 1: Two space-separated integers: N and M 

* Lines 2..N+1: M characters per line representing one row of Farmer John's field. Each character is either 'W' or '.'. The characters do not have spaces between them.

Output

* Line 1: The number of ponds in Farmer John's field.

Sample Input

10 12
W........WW.
.WWW.....WWW
....WW...WW.
.........WW.
.........W..
..W......W..
.W.W.....WW.
W.W.W.....W.
.W.W......W.
..W.......W.

Sample Output

3
 
  

解题思路:

本题即计算连通块的个数。可以从任意一个‘W’开始深搜,在深搜中,首先将遍历到的结点的字符改为‘.’,以免之后重复遍历该点。然后使用一个循环,检验与该点相邻的八个顶点是否为‘W’,如果为W,则继续使用dfs遍历该点。在solve中每次调用一次dfs即求得一个连通块,即将池塘的个数+1.

代码展示

<pre class="sh_cpp sh_sourceCode" style="background-color: white;font-size:14px; font-family: "Courier New", Courier, monospace;"><pre name="code" class="cpp">#include <iostream>
#include <fstream>
using namespace std;
int N , M;
const int max_N = 100;
const int max_M = 100;
char ans[max_N][max_M];
void dfs(int x, int y)
{
	ans[x][y]='.';
	for(int i=-1;i<=1;i++)
	{
		for(int j=-1;j<=1;j++)
		{
			int nx = x+i;
			int ny = y+j;
			if(nx>=0&&nx<N&&ny>=0&&ny<M&&ans[nx][ny]=='W') dfs(nx,ny);
		}
	}
}
void solve()
{
	int res =0;
	for(int i= 0;i<N;i++)
	{
		for(int j=0;j<M;j++)
		{
			if(ans[i][j]=='W')
			{
				dfs(i,j);
				res++;
			}
		}
	}
	cout<<res<<endl;
}
int main()
{
	//freopen("in.txt","r",stdin);
	cin>>N>>M;
	for(int i=0;i<N;i++)
	{
		for(int j=0;j<M;j++)
		{
			cin>>ans[i][j];
		}

	}
	solve();
	return 0;
}


 

                
  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值