HDU - 1024 Max Sum Plus Plus

本题是连续最大子序列和的加强版。

题目大意为 从一序列中取出若干段,使得这几段的和最大.

不得不说。。DP真的好难啊→ →

基本的连续最大子序列和代码为

#include<iostream>
#include<cstdio>
#include<cstring>
using namespace std;
int a[1234];
int main()
{
    int n;
    while(~scanf("%d",&n))
    {
        int i;
        for(i=0;i<=n-1;i++)
        {
            scanf("%d",&a[i]);
        }
        int sum=0;
        int m=0;
        for(i=0;i<=n-1;i++)
        {
            sum+=a[i];
            m=max(m,sum);
            if(sum<0)sum=0;
        }
        printf("%d\n",m);
    }
    return 0;
}
下面是题面:

Now I think you have got an AC in Ignatius.L's "Max Sum" problem. To be a brave ACMer, we always challenge ourselves to more difficult problems. Now you are faced with a more difficult problem.

Given a consecutive number sequence S 1, S 2, S 3, S 4 ... S x, ... S n (1 ≤ x ≤ n ≤ 1,000,000, -32768 ≤ S x ≤ 32767). We define a function sum(i, j) = S i + ... + S j (1 ≤ i ≤ j ≤ n).

Now given an integer m (m > 0), your task is to find m pairs of i and j which make sum(i 1, j 1) + sum(i 2, j 2) + sum(i 3, j 3) + ... + sum(i m, j m) maximal (i x ≤ i y ≤ j x or i x ≤ j y ≤ j x is not allowed).

But I`m lazy, I don't want to write a special-judge module, so you don't have to output m pairs of i and j, just output the maximal summation of sum(i x, j x)(1 ≤ x ≤ m) instead. ^_^

Input
Each test case will begin with two integers m and n, followed by n integers S 1, S 2, S 3 ... S n.
Process to the end of file.
Output
Output the maximal summation described above in one line.
Sample Input
1 3 1 2 3
2 6 -1 4 -2 3 -2 3
Sample Output
6
8


        
  
Hint
Huge input, scanf and dynamic programming is recommended.

        
 
我们可以先写出状态转移方程式:
dp[i][j]=max{dp[i][j-1]+a[j],max{dp[i-1][t]}+a[j]}    i-1=<t<j-1
但数组开不了这么大,而且三重循环肯定会超时。
所以做一下改进。
用dp[j]数组代表以j-1结尾i个子段的和,mm[j-1]数组代表以j-1结尾i-1个子段的和
这样用两个数组来存就大大节省了空间
然后就高高兴兴的AC啦!

#include<iostream>
#include<cstdio>
#include<cstring>
using namespace std;
const int INF=0x3f3f3f3f;
int a[1123456];
int dp[1123456];
int mm[1123456];
int main()
{
    int n,m;
    while(~scanf("%d%d",&m,&n))
    {
        int i,j;
        for(i=1;i<=n;i++)
        {
            scanf("%d",&a[i]);
            mm[i]=0;
            dp[i]=0;
        }
        dp[0]=0;
        mm[0]=0;
        int ma;
        for(i=1;i<=m;i++)
        {
            ma=-INF;
            for(j=i;j<=n;j++)
            {
                dp[j]=max(dp[j-1]+a[j],mm[j-1]+a[j]);//dp[j-1]表示的是以j-1结尾i个子段的和..mm[j-1]表示前j-1个元素i-1个子段的和
                mm[j-1]=ma;//保证a[i]是一个独立的子段
                ma=max(ma,dp[j]);
            }
        }
        printf("%d\n",ma);
    }
    return 0;
}


  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值