HDU4417_树状数组加离线

Mario is world-famous plumber. His “burly” figure and amazing jumping ability reminded in our memory. Now the poor princess is in trouble again and Mario needs to save his lover. We regard the road to the boss’s castle as a line (the length is n), on every integer point i there is a brick on height hi. Now the question is how many bricks in [L, R] Mario can hit if the maximal height he can jump is H.
Input
The first line follows an integer T, the number of test data.
For each test data:
The first line contains two integers n, m (1 <= n <=10^5, 1 <= m <= 10^5), n is the length of the road, m is the number of queries.
Next line contains n integers, the height of each brick, the range is [0, 1000000000].
Next m lines, each line contains three integers L, R,H.( 0 <= L <= R < n 0 <= H <= 1000000000.)
Output
For each case, output “Case X: ” (X is the case number starting from 1) followed by m lines, each line contains an integer. The ith integer is the number of bricks Mario can hit for the ith query.
Sample Input
1
10 10
0 5 2 7 5 4 3 8 7 7
2 8 6
3 5 0
1 3 1
1 9 4
0 1 0
3 5 5
5 5 1
4 6 3
1 5 7
5 7 3
Sample Output
Case 1:
4
0
0
3
1
2
0
1
5
1

#include <bits/stdc++.h>
using namespace std;
const int maxn=100002;
int cnt[maxn];
struct qu
{
    int l,r,val,id;
} q[maxn];
int cmp1(qu a,qu b)
{
    return a.val<b.val;
}
struct node
{
    int val,id;
} num[maxn];
int cmp2(node a,node b)
{
    return a.val<b.val;
}
int n,m,t;
int ans[maxn];
int lowbit(int x)
{
    return x&(-x);
}
void update(int x)
{
    while(x<=n)
    {
        cnt[x]++;
        x+=lowbit(x);
    }
}
int query(int x)
{
    int sum=0;
    while(x)
    {
        sum+=cnt[x];
        x-=lowbit(x);
    }
    return sum;
}
int main()
{
    scanf("%d",&t);
    for(int ase=1; ase<=t; ase++)
    {
        memset(cnt,0,sizeof cnt);
        scanf("%d%d",&n,&m);
        for(int i=1; i<=n; i++)
        {
            scanf("%d",&num[i].val);
            num[i].id=i;
        }
        sort(num+1,num+1+n,cmp2);
        int x,y;
        for(int i=1; i<=m; i++)
        {
            scanf("%d%d%d",&x,&y,&q[i].val);
            q[i].l=x+1;
            q[i].r=y+1;
            q[i].id=i;
        }
        sort(q+1,q+1+m,cmp1);
        for(int i=1,j=1;i<=m;i++)
        {
            while(j<=n&&q[i].val>=num[j].val)
            {
                update(num[j].id);
                j++;
            }
            ans[q[i].id]=query(q[i].r)-query(q[i].l-1);
        }
        printf("Case %d:\n",ase);
        for(int i=1;i<=m;i++)
            printf("%d\n",ans[i]);
    }
    return 0;
}
  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值