CISCO网络学习

1.range命令
3550(config)define interface-range kaifa fa0/1,fa0/3,fa0/5,fa0/6,fa0/9     //定义一组端口,准备集中操作
3550(config)interface range macro MultiPort1                               //定义为MultiPort1
3550(config-if-range)switch mode access                                    //进行操作
3550(config-if-range)switch access vlan 3

2.宏命令
3550#conf t
3550(config)alias exec 11 show ip bri                //定义11的操作为show ip bri
3550(config)alias exec 22 show ip bri | in unassigned
3550#11
3550#22

3.恢复操作(有很多缺省命令的执行,可以节省工作量)
Router#show run inter s1/1              //显示端口s1/1的状态
Router#conf t
Router(config)#default inter s1/1       //恢复某个端口到默认的状态

4.debug命令
debug和show都是查看命令,show看的是某一个时间点的状态,而debug查看的是动态的。
debug命令越具体,对系统的消耗就越小
r1#debug ip packet detail     //追踪数据包的细节
r1(config)access-list 100 permit icmp host 12.1.1.1 host 12.1.1.2       //允许12.1.1.1对12.1.1.2的ping包
r1(config)debug ip packet detail 100   //通过访问控制列表来限制debug对系统的消耗量

5.telnet
要使得可以telnet远程登录访问,做以下设置:
R2#conf t
R2(config)#line vty 0 4              //开启vty
R2(config-line)#login                //必须登录验证
R2(config-line)#password ccna        //设置密码为ccna
R2(config-line)#exit                 //    
R2(config)#enabled secret ccnp       //设置enabled的特权密码,为加密的特权密码:ccnp
R2(config)#end
在R1上telent访问,直接输入IP地址即可。
R1#12.1.1.1

6.每个登录用户有不同的密码
R2#conf t
R2(config)#username ccna password ccna
R2(config)#username ccnp password ccnp
R2(config)#username ccip nopassword
R2(config)#line vty 0 4
R2(config-line)#login local
R2(config)username ccna nopassword autocommand show ip inter bri     //用户ccna进入系统(不需要密码,也可以设置密码)后自动执行show ip inter bri命令

7.密码设置(最小长度)
r1(config)#security passwords min-length 8      //设置密码长度最小为8
r1(config)#enabled password 1234                //特权模式密码1234,长度不够,不能通过
r1(config)#enabled password 12345678            //特权模式密码12345678,长度为8,满足要求,可以通过
r1(config)#line vty 0 4
r1(config-line)#pass 1234                       //vty密码1234,长度不够,不能通过
r1(config-line)#enabled pass 12345678           //vty密码12345678,长度为8,通过

8.登录限制
r1(config)#login block-for 3600 attempts 5 within 60     //对于登录,在60秒内可以尝试5次,失败后需要等待3600秒(1小时)后再进行登录
r1(config)#login delay 3     //每次登录延时3秒
r1(config)#login on-failure log      //登录失败记录
r1(config)#login on-success log      //登录成功记录

//对于管理员的特权,通过IP地址来实现
r1#conf t
r1(config)#access-list 1 permit host 12.1.1.2         //只允许12.1.1.2
r1(config)#login quiet-mode access-class 1            //绑定上面的为1的访问控制列表

9.copy和write
r1#copy run start     //保存设置,这个需要确认
r1#write memory       //保存设置,不需要确认

//实现配置的自动保存
r1#conf t
r1(config)#kron  policy-list ccna                          //(在IOS12.3以后的版本都支持),定义一个自动执行的命令
r1(config-kron-policy)#cli write memory                    //具体命令 write memory(注意不需要交互确认的命令,只能执行特权模式下命令,不能在端口和全局模式下的命令)
r1(config)#kron occurrence everyday at 16:10 recurring     //周期性执行的命令everyday,每天16:10执行
r1(config-kron-occurrence)#polciy-list ccna                //每天执行的命令是ccna里面定义好的
r1(config-kron-occurrence)#end

//eem也是自动执行的命令

10.管道命令
R1#show ip inter brief | exclude unassigned        //查看所有配了IP的地址
R1#show run | begin line con 0                     //查看运行配置里面的所有从line con 0以后的内容
R1#show run | include ip route                     //查看运行配置里面的静态路由设置
R1#show run | section route ospf 1                 //只查看输入命令route ospf 1的内容,只查看某一部分
R1#show ip interface brief | include unassigned    //查看所有没有配置地址的端口

以下资料来自于网络,特此说明,但出处无法找到。

1:进入特权模式
switch>enable
--------------------------------------------------------------------------------
2:进入全局配置模式
switch>enable
switch#configure terminal
switch(conf)#
--------------------------------------------------------------------------------
3:交换机命名
switch(conf)#hostname Cisco9Floor
Cisco9Floor(conf)#
-------------------------------------------------------------------------------------------
4:配置使能口令
switch>enable
switch#configure terminal
switch(conf)#hostname Cisco9Floor
Cisco9Floor(conf)#enable password cisco
-------------------------------------------------------------------------------------------
5:配置使能密码
switch>enable
switch#configure terminal
switch(conf)#hostname Cisco9Floor
Cisco9Floor(conf)#enable secret ciscolab
-------------------------------------------------------------------------------------------
6:设置虚拟局域网
switch>enable
switch#configure terminal
switch(conf)#hostname Cisco9Floor
Cisco9Floor(conf)# interface vlan 1
Cisco9Floor(conf-if)#ip address 192.168.1.1 255.255.255.0   配置交换机端口ip和子网掩码
Cisco9Floor(conf-if)#no shut                是配置处于运行中
Cisco9Floor(conf-if)#exit
Cisco9Floor(conf)#ip default-gateway 192.168.1.254      设置网关地址
-------------------------------------------------------------------------------------------
7:进入交换机某一端口
switch>enable
switch#configure terminal
switch(conf)#hostname Cisco9Floor
Cisco9Floor(conf)# interface fastehernet 0/17
Cisco9Floor(conf-if)#
-------------------------------------------------------------------------------------------
8:查看命令
switch>enable
switch# show version   察看系统中的所有版本信息
show interface vlan 1   查看交换机有关ip 协议的配置信息
show running-configure 查看交换机当前起作用的配置信息
show interface fastethernet 0/1   察看交换机1接口具体配置和统计信息
show mac-address-table         查看mac地址表
show mac-address-table aging-time   查看mac地址表自动老化时间
-------------------------------------------------------------------------------------------
9:交换机恢复出厂默认恢复命令  
switch>enable
switch# erase startup-configure
switch# reload
-------------------------------------------------------------------------------------------
10:双工模式设置
switch>enable
switch#configure terminal
switch2950(conf)#hostname Cisco9Floor
Cisco9Floor(conf)#interface fastehernet 0/17        以17端口为例
Cisco9Floor(conf-if)#duplex full/half/auto         有full , half, auto 三个可选项
-------------------------------------------------------------------------------------------
11:cdp相关命令
switch>enable
switch# show cdp     查看设备的cdp全局配置信息
show cdp interface fastethernet 0/17     查看17端口的cdp配置信息
show cdp traffic      查看有关cdp包的统计信息
show cdp nerghbors   列出与设备相连的cisco设备
-------------------------------------------------------------------------------------------
12:csico2950的密码恢复
拔下交换机电源线。
用手按着交换机的MODE键,插上电源线
在switch:后执行flash_ini命令:switch: flash_ini
查看flash中的文件: switch: dir flash:
把“config.text”文件改名为“config.old”: switch: rename flash: config.text flash: config.old
执行boot:    switch: boot
交换机进入是否进入配置的对话,执行no : 
进入特权模式察看flash里的文件: show flash : 
把“config.old”文件改名为 “config.text”:switch: rename flash: config.old flash: config.text
把“config.text”拷入系统的“running-configure”: copy flash: config.text system : running-configure
把配置模式重新设置密码存盘,密码恢复成功。
-------------------------------------------------------------------------------------------
13:交换机telnet远程登录设置:
switch>en
switch#configure terminal
switch(conf)#hostname Cisco9Floor
Cisco9Floor(conf)#enable password cisco           以cisco为特权模式密码
Cisco9Floor(conf)#interface fastethernet 0/1         以17端口为telnet远程登录端口
Cisco9Floor(conf-if)#ip address 192.168.1.1 255.255.255.0
Cisco9Floor(conf-if)#no shut
Cisco9Floor(conf-if)#exit
Cisco9Floor(conf)line vty 0 4        设置0-4 个用户可以telnet远程登陆
Cisco9Floor(conf-line)#login
Cisco9Floor(conf-line)#password test     以edge为远程登录的用户密码
主机设置:
ip 192.168.1.2 主机的ip必须和交换机端口的地址在同一网络段
netmask 255.255.255.0
gate-way 192.168.1.1 网关地址是交换机端口地址
运行:
telnet 192.168.1.1 
进入telnet远程登录界面
password : test                
Cisco9Floor>en
password: cisco
Cisco9Floor#
-------------------------------------------------------------------------------------------
14:交换机配置的重新载入和保存
设置完成交换机的配置后:
Cisco9Floor(conf)#reload
是否保存(y/n)    y: 保存设置信息         n:不保存设置信息
-------------------------------------------------------------------------------------------
1.在基于IOS的交换机上设置主机名/系统名: 
switch(config)# hostname hostname 
在基于CLI的交换机上设置主机名/系统名: 
switch(enable) set system name name-string
-------------------------------------------------------------------------------------------
2.在基于IOS的交换机上设置登录口令: 
switch(config)#enable password level 1 password 
在基于CLI的交换机上设置登录口令: 
switch(enable) set password 
switch(enable) set enalbepass
-------------------------------------------------------------------------------------------
3.在基于IOS的交换机上设置远程访问: 
switch(config)# interface vlan 1 
switch(config-if)# ip address ip-address netmask 
switch(config-if)# ip default-gateway ip-address 
在基于CLI的交换机上设置远程访问: 
switch(enable) set interface sc0 ip-address netmask broadcast-address 
switch(enable) set interface sc0 vlan 
switch(enable) set ip route default gateway
-------------------------------------------------------------------------------------------
4.在基于IOS的交换机上启用和浏览CDP信息: 
switch(config-if)# cdp enable 
switch(config-if)# no cdp enable 
为了查看Cisco邻接设备的CDP通告信息: 
switch# show cdp interface [type modle/port] 
switch# show cdp neighbors [type module/port] [detail] 
在基于CLI的交换机上启用和浏览CDP信息: 
switch(enable) set cdp {enable|disable} module/port 
为了查看Cisco邻接设备的CDP通告信息: 
switch(enable) show cdp neighbors[module/port] [vlan|duplex|capabilities|detail]
-------------------------------------------------------------------------------------------
5.基于IOS的交换机的端口描述: 
switch(config-if)# description description-string 
基于CLI的交换机的端口描述: 
switch(enable)set port name module/number description-string
-------------------------------------------------------------------------------------------
6.在基于IOS的交换机上设置端口速度: 
switch(config-if)# speed{10|100|auto} 
在基于CLI的交换机上设置端口速度: 
switch(enable) set port speed moudle/number {10|100|auto} 
switch(enable) set port speed moudle/number {4|16|auto}
-------------------------------------------------------------------------------------------
7.在基于IOS的交换机上设置以太网的链路模式: 
switch(config-if)# duplex {auto|full|half} 
在基于CLI的交换机上设置以太网的链路模式: 
switch(enable) set port duplex module/number {full|half}
-------------------------------------------------------------------------------------------
8.在基于IOS的交换机上配置静态VLAN: 
switch# vlan database 
switch(vlan)# vlan vlan-num name vla
switch(vlan)# exit 
switch# configure teriminal 
switch(config)# interface interface module/number 
switch(config-if)# switchport mode access 
switch(config-if)# switchport access vlan vlan-num 
switch(config-if)# end 
在基于CLI的交换机上配置静态VLAN: 
switch(enable) set vlan vlan-num [name name] 
switch(enable) set vlan vlan-num mod-num/port-list
-------------------------------------------------------------------------------------------
9. 在基于IOS的交换机上配置VLAN中继线: 
switch(config)# interface interface mod/port 
switch(config-if)# switchport mode trunk 
switch(config-if)# switchport trunk encapsulation {isl|dotlq} 
switch(config-if)# switchport trunk allowed vlan remove vlan-list 
switch(config-if)# switchport trunk allowed vlan add vlan-list 
在基于CLI的交换机上配置VLAN中继线: 
switch(enable) set trunk module/port [on|off|desirable|auto|nonegotiate] 
Vlan-range [isl|dotlq|dotl0|lane|negotiate]
-------------------------------------------------------------------------------------------
10.在基于IOS的交换机上配置VTP管理域: 
switch# vlan database 
switch(vlan)# vtp domain domain-name 
在基于CLI的交换机上配置VTP管理域: 
switch(enable) set vtp [domain domain-name]
-------------------------------------------------------------------------------------------
11.在基于IOS的交换机上配置VTP 模式: 
switch# vlan database 
switch(vlan)# vtp domain domain-name 
switch(vlan)# vtp {sever|cilent|transparent} 
switch(vlan)# vtp password password 
在基于CLI的交换机上配置VTP 模式: 
switch(enable) set vtp [domain domain-name] [mode{ sever|cilent|transparent }][password password]
-------------------------------------------------------------------------------------------
12. 在基于IOS的交换机上配置VTP版本: 
switch# vlan database 
switch(vlan)# vtp v2-mode 
在基于CLI的交换机上配置VTP版本: 
switch(enable) set vtp v2 enable
-------------------------------------------------------------------------------------------
13. 在基于IOS的交换机上启动VTP剪裁: 
switch# vlan database 
switch(vlan)# vtp pruning 
在基于CL I 的交换机上启动VTP剪裁: 
switch(enable) set vtp pruning enable
14.在基于IOS的交换机上配置以太信道: 
switch(config-if)# port group group-number [distribution {source|destination}] 
在基于CLI的交换机上配置以太信道: 
switch(enable) set port channel moudle/port-range mode{on|off|desirable|auto}
-------------------------------------------------------------------------------------------
15.在基于IOS的交换机上调整根路径成本: 
switch(config-if)# spanning-tree [vlan vlan-list] cost cost 
在基于CLI的交换机上调整根路径成本:
switch(enable) set spantree portcost moudle/port cost 
switch(enable) set spantree portvlancost moudle/port [cost cost][vlan-list]
-------------------------------------------------------------------------------------------
16.在基于IOS的交换机上调整端口ID: 
switch(config-if)# spanning-tree[vlan vlan-list]port-priority port-priority 
在基于CLI的交换机上调整端口ID: 
switch(enable) set spantree portpri {mldule/port}priority 
switch(enable) set spantree portvlanpri {module/port}priority [vlans]
-------------------------------------------------------------------------------------------
17. 在基于IOS的交换机上修改STP时钟: 
switch(config)# spanning-tree [vlan vlan-list] hello-time seconds 
switch(config)# spanning-tree [vlan vlan-list] forward-time seconds 
` switch(config)# spanning-tree [vlan vlan-list] max-age seconds 
在基于CLI的交换机上修改STP时钟: 
switch(enable) set spantree hello interval[vlan] 
switch(enable) set spantree fwddelay delay [vlan] 
switch(enable) set spantree maxage agingtiame[vlan]
-------------------------------------------------------------------------------------------
18. 在基于IOS的交换机端口上启用或禁用Port Fast 特征: 
switch(config-if)#spanning-tree portfast 
在基于CLI的交换机端口上启用或禁用Port Fast 特征: 
switch(enable) set spantree portfast {module/port}{enable|disable}
-------------------------------------------------------------------------------------------
19. 在基于IOS的交换机端口上启用或禁用UplinkFast 特征: 
switch(config)# spanning-tree uplinkfast [max-update-rate pkts-per-second] 
在基于CLI的交换机端口上启用或禁用UplinkFast 特征: 
switch(enable) set spantree uplinkfast {enable|disable}[rate update-rate] [all-protocols off|on]
-------------------------------------------------------------------------------------------
20. 为了将交换机配置成一个集群的命令交换机,首先要给管理接口分配一个IP地址,然后使用下列命令: switch(config)# cluster enable cluster-name
-------------------------------------------------------------------------------------------
21. 为了从一条中继链路上删除VLAN,可使用下列命令: 
switch(enable) clear trunk module/port vlan-range
-------------------------------------------------------------------------------------------
22. 用show vtp domain 显示管理域的VTP参数.
-------------------------------------------------------------------------------------------
23. 用show vtp statistics显示管理域的VTP参数.
-------------------------------------------------------------------------------------------
24. 在Catalyst交换机上定义TrBRF的命令如下: 
switch(enable) set vlan vlan-name [name name] type trbrf bridge bridge-num[stp {ieee|ibm}]
-------------------------------------------------------------------------------------------
25. 在Catalyst交换机上定义TrCRF的命令如下: 
switch (enable) set vlan vlan-num [name name] type trcrf 
{ring hex-ring-num|decring decimal-ring-num} parent vlan-num
-------------------------------------------------------------------------------------------
26. 在创建好TrBRF VLAN之后,就可以给它分配交换机端口.对于以太网交换,可以采用如下命令给VLAN分配端口: 
switch(enable) set vlan vlan-num mod-num/port-num
-------------------------------------------------------------------------------------------
27. 命令show spantree显示一个交换机端口的STP状态.
-------------------------------------------------------------------------------------------
28. 配置一个ELAN的LES和BUS,可以使用下列命令: 
ATM (config)# interface atm number.subint multioint 
ATM(config-subif)# lane serber-bus ethernet elan-name
-------------------------------------------------------------------------------------------
29. 配置LECS: 
ATM(config)# lane database database-name 
ATM(lane-config-databade)# name elan1-name server-atm-address les1-nsap-address 
ATM(lane-config-databade)# name elan2-name server-atm-address les2-nsap-address 
ATM(lane-config-databade)# name …
-------------------------------------------------------------------------------------------
30. 创建完数据库后,必须在主接口上启动LECS.命令如下: 
ATM(config)# interface atm number 
ATM(config-if)# lane config database database-name 
ATM(config-if)# lane config auto-config-atm-address
-------------------------------------------------------------------------------------------
31. 将每个LEC配置到一个不同的ATM子接口上.命令如下: 
ATM(config)# interface atm number.subint multipoint 
ATM(config)# lane client ethernet vlan-num elan-num
-------------------------------------------------------------------------------------------
32. 用show lane server 显示LES的状态.
-------------------------------------------------------------------------------------------
33. 用show lane bus显示bus的状态.
-------------------------------------------------------------------------------------------
34. 用show lane database显示LECS数据库可内容.
-------------------------------------------------------------------------------------------
35. 用show lane client显示LEC的状态.
-------------------------------------------------------------------------------------------
36. 用show module显示已安装的模块列表.
-------------------------------------------------------------------------------------------
37. 用物理接口建立与VLAN的连接: 
router# configure terminal 
router(config)# interface media module/port 
router(config-if)# description description-string 
router(config-if)# ip address ip-addr subnet-mask 
router(config-if)# no shutdown
-------------------------------------------------------------------------------------------
38. 用中继链路来建立与VLAN的连接: 
router(config)# interface module/port.subinterface 
router(config-ig)# encapsulation[isl|dotlq] vlan-number 
router(config-if)# ip address ip-address subnet-mask
-------------------------------------------------------------------------------------------
39. 用LANE 来建立与VLAN的连接: 
router(config)# interface atm module/port 
router(config-if)# no ip address 
router(config-if)# atm pvc 1 0 5 qsaal 
router(config-if)# atm pvc 2 0 16 ilni 
router(config-if)# interface atm module/port.subinterface multipoint 
router(config-if)# ip address ip-address subnet-mask 
router(config-if)# lane client ethernet elan-num 
router(config-if)# interface atm module/port.subinterface multipoint 
router(config-if)# ip address ip-address subnet-name 
router(config-if)# lane client ethernet elan-name 
router(config-if)# …
-------------------------------------------------------------------------------------------
40. 为了在路由处理器上进行动态路由配置,可以用下列IOS命令来进行: 
router(config)# ip routing 
router(config)# router ip-routing-protocol 
router(config-router)# network ip-network-number 
router(config-router)# network ip-network-number
-------------------------------------------------------------------------------------------
41. 配置默认路由: 
switch(enable) set ip route default gateway
-------------------------------------------------------------------------------------------
42. 为一个路由处理器分配VLANID,可在接口模式下使用下列命令: 
router(config)# interface interface number 
router(config-if)# mls rp vlan-id vlan-id-num
-------------------------------------------------------------------------------------------
43. 在路由处理器启用MLSP: 
router(config)# mls rp ip
-------------------------------------------------------------------------------------------
44. 为了把一个外置的路由处理器接口和交换机安置在同一个VTP域中: 
router(config)# interface interface number 
router(config-if)# mls rp vtp-domain domain-name
-------------------------------------------------------------------------------------------
45. 查看指定的VTP域的信息: 
router# show mls rp vtp-domain vtp domain name
-------------------------------------------------------------------------------------------
46. 要确定RSM或路由器上的管理接口,可以在接口模式下输入下列命令: 
router(config-if)#mls rp management-interface
-------------------------------------------------------------------------------------------
47. 要检验MLS-RP的配置情况: 
router# show mls rp
-------------------------------------------------------------------------------------------
48. 检验特定接口上的MLS配置: 
router# show mls rp interface interface number
-------------------------------------------------------------------------------------------
49. 为了在MLS-SE上设置流掩码而又不想在任一个路由处理器接口上设置访问列表: 
set mls flow [destination|destination-source|full]
-------------------------------------------------------------------------------------------
50. 为使MLS和输入访问列表可以兼容,可以在全局模式下使用下列命令: 
router(config)# mls rp ip input-acl
-------------------------------------------------------------------------------------------
51. 当某个交换机的第3层交换失效时,可在交换机的特权模式下输入下列命令: 
switch(enable) set mls enable
-------------------------------------------------------------------------------------------
52. 若想改变老化时间的值,可在特权模式下输入以下命令: 
switch(enable) set mls agingtime agingtime
-------------------------------------------------------------------------------------------
53. 设置快速老化: 
switch(enable) set mls agingtime fast fastagingtime pkt_threshold
-------------------------------------------------------------------------------------------
54. 确定那些MLS-RP和MLS-SE参与了MLS,可先显示交换机引用列表中的内容再确定: 
switch(enable) show mls include
-------------------------------------------------------------------------------------------
55. 显示MLS高速缓存记录: 
switch(enable) show mls entry
-------------------------------------------------------------------------------------------
56. 用命令show in arp显示ARP高速缓存区的内容。
-------------------------------------------------------------------------------------------
57. 要把路由器配置为HSRP备份组的成员,可以在接口配置模式下使用下面的命令: 
router(config-if)# standby group-number ip ip-address
-------------------------------------------------------------------------------------------
58. 为了使一个路由器重新恢复转发路由器的角色,在接口配置模式下: 
router(config-if)# standy group-number preempt
-------------------------------------------------------------------------------------------
59. 访问时间和保持时间参数是可配置的: 
router(config-if)# standy group-number timers hellotime holdtime
-------------------------------------------------------------------------------------------
60. 配置HSRP跟踪: 
router(config-if)# standy group-number track type-number interface-priority
-------------------------------------------------------------------------------------------
61. 要显示HSRP路由器的状态: 
router# show standby type-number group brief
-------------------------------------------------------------------------------------------
62. 用命令show ip igmp确定当选的查询器。
-------------------------------------------------------------------------------------------
63. 启动IP组播路由选择: 
router(config)# ip muticast-routing
-------------------------------------------------------------------------------------------
64. 启动接口上的PIM: 
dalllasr1>(config-if)# ip pim {dense-mode|sparse-mode|sparse-dense-mode}
-------------------------------------------------------------------------------------------
65. 启动稀疏-稠密模式下的PIM: 
router# ip multicast-routing 
router# interface type number 
router# ip pim sparse-dense-mode
-------------------------------------------------------------------------------------------
66. 核实PIM的配置: 
dallasr1># show ip pim interface[type number] [count]
-------------------------------------------------------------------------------------------
67. 显示PIM邻居: 
dallasr1># show ip neighbor type number
-------------------------------------------------------------------------------------------
68. 为了配置RP的地址,命令如下: 
dallasr1># ip pim rp-address ip-address [group-access-list-number][override]
-------------------------------------------------------------------------------------------
69. 选择一个默认的RP: 
dallasr1># ip pim rp-address 
通告RP和它所服务的组范围: 
dallasr1># ip pim send-rp-announce type number scope ttl group-list access-list-number 
为管理范围组通告RP的地址: 
dallasr1># ip pim send-rp-announce ethernet0 scope 16 group-list1 
dallasr1># access-list 1 permit 266.0.0.0 0.255.255.255 
设定一个RP映像代理: 
dallasr1># ip pim send-rp-discovery scope ttl 
核实组到RP的映像: 
dallasr1># show ip pim rp mapping 
dallasr1># show ip pim rp [group-name|group-address] [mapping]
-------------------------------------------------------------------------------------------
70. 在路由器接口上用命令ip multicast ttl-threshold ttl-value设定TTL阀值: 
dallasr1>(config-if)# ip multicast ttl-threshold ttl-value
-------------------------------------------------------------------------------------------
71. 用show ip pim neighbor显示PIM邻居表。
-------------------------------------------------------------------------------------------
72. 显示组播通信路由表中的各条记录: 
dallasr1>show ip mroute [group-name|group-address][scoure][summary][count][active kbps]
-------------------------------------------------------------------------------------------
73. 要记录一个路由器接受和发送的全部IP组播包: 
dallasr1> #debug ip mpacket [detail] [access-list][group]
-------------------------------------------------------------------------------------------
74. 要在CISCO路由器上配置CGMP: 
dallasr1>(config-if)# ip cgmp
-------------------------------------------------------------------------------------------
75.配置一个组播路由器,使之加入某一个特定的组播组: 
dallasr1>(config-if)# ip igmp join-group group-address
-------------------------------------------------------------------------------------------
76. 关闭 CGMP: 
dallasr1>(config-if)# no ip cgmp
-------------------------------------------------------------------------------------------
77. 启动交换机上的CGMP: 
dallasr1>(enable) set cgmp enable
-------------------------------------------------------------------------------------------
78. 核实Catalyst交换机上CGMP的配置情况: 
catalystla1>(enable) show config 
set prompt catalystla1> 
set interface sc0 192.168.1.1 255.255.255.0 
set cgmp enable
-------------------------------------------------------------------------------------------
79. CGMP离开的设置: 
Dallas_SW(enable) set cgmp leave
-------------------------------------------------------------------------------------------
80. 在Cisco设备上修改控制端口密码: 
R1(config)# line console 0 
R1(config-line)# login 
R1(config-line)# password Lisbon 
R1(config)#enable password Lilbao 
R1(config)# login local 
R1(config)# username student password cisco
-------------------------------------------------------------------------------------------
81. 在Cisco设备上设置控制台及vty端口的会话超时: 
R1(config)# line console 0 
R1(config-line)# exec-timeout 5 10 
R1(config)# line vty 0 4 
R1(config-line)# exec-timeout 5 2
-------------------------------------------------------------------------------------------
82. 在Cisco设备上设定特权级: 
R1(config)# privilege configure level 3 username 
R1(config)# privilege configure level 3 copy run start 
R1(config)# privilege configure level 3 ping 
R1(config)# privilege configure level 3 show run 
R1(config)#enable secret level 3 cisco
-------------------------------------------------------------------------------------------
83. 使用命令privilege 可定义在该特权级下使用的命令: 
router(config)# privilege mode level level command
-------------------------------------------------------------------------------------------
84. 设定用户特权级: 
router(config)#enable secret level 3 dallas 
router(config)#enable secret san-fran 
router(config)# username student password cisco
-------------------------------------------------------------------------------------------
85. 标志设置与显示: 
R1(config)# banner motd ‘unauthorized access will be prosecuted!’
-------------------------------------------------------------------------------------------
86. 设置vty访问: 
R1(config)# access-list 1 permit 192.168.2.5 
R1(config)# line vty 0 4 
R1(config)# access-class 1 in
-------------------------------------------------------------------------------------------
87. 配置HTTP访问: 
Router3(config)# access-list 1 permit 192.168.10.7 
Router3(config)# ip http sever 
Router3(config)# ip http access-class 1 
Router3(config)# ip http authentication local 
Router3(config)# username student password cisco
-------------------------------------------------------------------------------------------
88. 要启用HTTP访问,请键入以下命令: 
switch(config)# ip http sever
-------------------------------------------------------------------------------------------
89. 在基于set命令的交换机上用setCL1启动和核实端口安全: 
switch(enable) set port security mod_num/port_num…enable mac address 
switch(enable) show port mod_num/port_num 
在基于CiscoIOS命令的交换机上启动和核实端口安全: 
switch(config-if)# port secure [mac-mac-count maximum-MAC-count] 
switch# show mac-address-table security [type module/port]
-------------------------------------------------------------------------------------------
90. 用命令access-list在标准通信量过滤表中创建一条记录: 
Router(config)# access-list access-list-number {permit|deny} source-address [source-address]
-------------------------------------------------------------------------------------------
91. 用命令access-list在扩展通信量过滤表中创建一条记录: 
Router(config)# access-list access-list-number {permit|deny{protocol|protocol-keyword}}{source source-wildcard|any}{destination destination-wildcard|any}[protocol-specific options][log]
-------------------------------------------------------------------------------------------
92. 对于带内路由更新,配置路由更新的最基本的命令格式是: 
R1(config-router)#distribute-list access-list-number|name in [type number]
-------------------------------------------------------------------------------------------
93. 对于带外路由更新,配置路由更新的最基本的命令格式是: 
R1(config-router)#distribute-list access-list-number|name out [interface-name] routing-process| autonomous-system-number
-------------------------------------------------------------------------------------------
94. set snmp命令选项: 
set snmp community {read-only|ready-write|read-write-all}[community_string]
-------------------------------------------------------------------------------------------
95. set snmp trap 命令格式如下: 
set snmp trap {enable|disable} 
[all|moudle|classis|bridge|repeater| auth|vtp|ippermit|vmps|config|entity|stpx] 
set snmp trap rvcr_addr rcvr_community
-------------------------------------------------------------------------------------------
96. 启用SNMP chassis 陷阱: 
Console>(enable) set snmp trap enable chassis
-------------------------------------------------------------------------------------------
97. 启用所有SNMP chassis 陷阱: 
Console>(enable) set snmp trap enable
…………以下由about于2002年12月6日增加…………
-------------------------------------------------------------------------------------------
98. 禁用SNMP chassis 陷阱:
Console>(enable) set snmp trap disable chassis
-------------------------------------------------------------------------------------------
99. 给SNMP陷阱接收表加一条记录:
Console>(enable) set snmp trap 192.122.173.42 public
-------------------------------------------------------------------------------------------
100. show snmp 输出结果。
-------------------------------------------------------------------------------------------
101. 命令set snmp rmon enable 的输出结果。
-------------------------------------------------------------------------------------------
102. 显示SPAN信息:
Consile>show span

  以下资料来自于网络,特此说明。

Cisco交换机常用配置命令总结

1:配置VLAN                                                           
理解VLAN: 一个VLAN就是一个交换网,其逻辑上按功能、项目、应用来分而不必考虑用户的物理位置。任何交换口都可以属于某一VLAN, IP包、广播包及组播包均可以发送或广播给在此VLAN内的最终用户。每一个VLAN均可看成是一个逻辑网络,发往另一VLAN的数据包必须由路由器或网桥转发,由于VLAN被看成是一个逻辑网络,其具有自己的网桥管理信息库 (MIB) 并可支持自己的生成树。
在Cisco交换机里面有两种配置Vlan的方法:
Switch# configure terminal
Switch(config)# vlan 20 
Switch(config-vlan)# name test20
Switch(config-vlan)# end 
也可以在enable状态下,进行VLAN配置:
Switch# vlan database
Switch(vlan)# vlan 20 name test20 
Switch(vlan)# exit 
删除VLAN 
当删除一个处于VTP服务器的交换机上删除VLAN时,则此VLAN将在所有相同VTP的交换机上删除。当在透明模式下删除时,只在当前交换机上删除,用vlan database 进入VLAN配置状态,用no vlan vlan-id 来删除。 
Switch# vlan database 
Switch(vlan)# no vlan 20
Switch(vlan)# exit 
将端口分配给一个VLAN
Switch# configure terminal
Switch(config)# interface fastethernet0/1 
Switch(config-if)# switchport mode access 
Switch(config-if)# switchport access vlan 2 
Switch(config-if)# end                                                                             
2:配置VLAN Trunks 
所谓的TRUNK是用来在不同的交换机之间进行连接,以保证在跨越多个交换机上建立的同一个VLAN的成员能够相互通讯,如果是不同台的交换机上相同id的vlan要相互通信,那么可以通过共享的trunk端口就可以实现,如果是不同台不同id的vlan它们之间要相互通信,需要通过第三方的路由来实现.
Switch# configure terminal 
Switch(config)# interface fastetherne2/4 
Switch(config-if)# switchport mode trunk 
Switch(config-if)# switchport trunk encapsulation dot1q 
Switch(config-if)# end 
定义trunk允许的VLAN 
缺省情况下trunk允许所有的VLAN通过,可以使用 switchport trunk allowed vlan remove vlan-list 来去掉某一VLAN 
Switch(config)# interface fastethernet2/4 
Switch(config-if)# switchport trunk allowed vlan remove 2 
Switch(config-if)# end                                                                               
3:使用STP实现负载均衡 
负载均衡可以使用流量分流到其它平行的trunks上去. 交换机为了避免环路,STP通常是阻断所有端口交换机之间只留一条链路,使用负载均衡后, 可以把不同VLAN的流量分配到不同的trunk上。
可以通过配置STP端口权值STP路径值来实现负载均衡,如果使用STP端口权值来配置那么二条负载均衡的trunk必须联同一交换机上;使用路径值则即可以联相同的交换机与可以联不同的交换机。
使用STP端口权值的负载均衡 
当同一台交换机的二个口形成环路时, STP端口权值用来决定那个口是enable的,那个口是阻断的。 可以通过配置端口权值来决定二对trunk各走那些VLAN, 有较高权值的端口(数字较小的)vlan, 将处于转发状态,同一个VLAN在另一个trunk有较低的权值(数字较大)则将处在阻断状态,即同一VLAN只在一个trunk上发送接受。
基于端口权值的负载均衡,trunk1将发送和接收VLAN8-10的数据,trunk2将发送和接收VLAN3-5的数据
interface fastethernet0/1  (进入Trunk1口)
spanning-tree vlan 8 port-priority 10
spanning-tree vlan 9 port-priority 10
spanning-tree vlan 10 port-priority 10
interface fastethernet0/2  (进入Trunk2口) 
spanning-tree vlan 3 port-priority 10 
spanning-tree vlan 4 port-priority 10 
spanning-tree vlan 5 port-priority 10
也可以通过配置配置STP路径值来实现负载均衡,Trunk1走VLAN8-10,Trunk2走VLAN2-4
interface fastethernet 0/1 (进入Trunk1口)
spanning-tree vlan 8 cost 30
spanning-tree vlan 9 cost 30
spanning-tree vlan 10 cost 30
interface fastethernet 0/2 (进入Trunk2口) 
spanning-tree vlan 2 cost 30 
spanning-tree vlan 3 cost 30 
spanning-tree vlan 4 cost 30
4:配置EtherChannel 
etherchannel特性在switch到switch、switch到router之间提供冗余的、高速的连接方式,简单说就是将两个设备间多条 fe或ge物理链路捆在一起组成一条设备间逻辑链路,从而达到增加带宽,提供冗余的目的,每个以太通道具有一个port-channel端口号,要捆绑一个以太通道时,会产生一个逻辑port-channel端口,逻辑端口下的配置可影响与之捆绑的物理端口,但物理端口下的配置不能影响逻辑端口的配置
Switch# configure terminal
Switch(config)# interface port-channel 1
Switch(config-if)# ip address 172.16.30.10 255.255.255.0
Switch(config-if)# end
三层物理端口配置
Switch# configure terminal
Switch(config)# interface range fastethernet 3/4 - 5 
Switch(config-if)# no switchport
Switch(config-if)# no ip address
Switch(config-if)# channel-group 1 mode desirable
Switch(config-if)# end
二层以太通道配置 
Switch# configure terminal
Switch(config)# interface range fastethernet 2/6 - 7 
Switch(config-if-range)# channel-group 2 mode desirable
Switch(config-if-range)# end
5:配置以太通道负载均衡 
负载均衡关键字表示如下:
src-mac—源MAC地址
dst-mac—目标MAC地址
src-dst-mac—源和目标MAC地址
src-ip—源IP地址
dst-ip—目标IP地址
src-dst-ip—源和目标IP地址 (缺省)
src-port—源第四层端口
dst-port—目标第四层端口
src-dst-port—源和目标第四层端口
Switch(config)# port-channel load-balance src-dst-ip
Switch(config)# end
This example shows how to verify the configuration:
Switch# show etherchannel load-balance
Source XOR Destination IP address
Switch#

  • 0
    点赞
  • 9
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值