AtCoder Regular Contest 077 D - 11

D - 11


Time limit : 2sec / Memory limit : 256MB

Score : 600 points

Problem Statement

You are given an integer sequence of length n+1a1,a2,…,an+1, which consists of the n integers 1,…,n. It is known that each of the n integers 1,…,n appears at least once in this sequence.

For each integer k=1,…,n+1, find the number of the different subsequences (not necessarily contiguous) of the given sequence with length k, modulo 109+7.

Notes

  • If the contents of two subsequences are the same, they are not separately counted even if they originate from different positions in the original sequence.

  • A subsequence of a sequence a with length k is a sequence obtained by selecting k of the elements of a and arranging them without changing their relative order. For example, the sequences 1,3,5 and 1,2,3 are subsequences of 1,2,3,4,5, while 3,1,2 and 1,10,100 are not.

Constraints

  • 1≤n≤105
  • 1≤ain
  • Each of the integers 1,…,n appears in the sequence.
  • n and ai are integers.

Input

Input is given from Standard Input in the following format:

n
a1 a2 ... an+1

Output

Print n+1 lines. The k-th line should contain the number of the different subsequences of the given sequence with length k, modulo 109+7.


Sample Input 1

3
1 2 1 3

Sample Output 1

3
5
4
1

There are three subsequences with length 11 and 2 and 3.

There are five subsequences with length 21,1 and 1,2 and 1,3 and 2,1 and 2,3.

There are four subsequences with length 31,1,3 and 1,2,1 and 1,2,3 and 2,1,3.

There is one subsequence with length 41,2,1,3.


Sample Input 2

1
1 1

Sample Output 2

1
1

There is one subsequence with length 11.

There is one subsequence with length 21,1.


Sample Input 3

32
29 19 7 10 26 32 27 4 11 20 2 8 16 23 5 14 6 12 17 22 18 30 28 24 15 1 25 3 13 21 19 31 9

Sample Output 3

32
525
5453
40919
237336
1107568
4272048
13884156
38567100
92561040
193536720
354817320
573166440
818809200
37158313
166803103
166803103
37158313
818809200
573166440
354817320
193536720
92561040
38567100
13884156
4272048
1107568
237336
40920
5456
528
33
1

Be sure to print the numbers modulo 109+7.

 

很烦,最后结果忘记取模,求逆元忘记可能为负。

假设n+1个数互不相同,正确结果=C(n+1,i) - 实际重复的情况。

#include<cstdio>
#include<cstdlib>
#include<cstring>
#include<string>
#include<algorithm>
#include<iostream>
#include<queue>
#include<map>
#include<cmath>
#include<set>
#include<stack>
#define ll long long
#define pb push_back
#define max(x,y) ((x)>(y)?(x):(y))
#define min(x,y) ((x)>(y)?(y):(x))
#define cls(name,x) memset(name,x,sizeof(name))
using namespace std;
const int inf=1e9+10;
const ll llinf=1e16+10;
const int maxn=1e5+10;
const int maxm=1e5+10;
const int mod=1e9+7;
const double pi=acos(-1.0);
int n;
int vis[maxn];
int num[maxn];
ll a,b;
ll ca[maxn];
ll cb[maxn];

ll exgcd(ll a,ll b,ll &x,ll &y)
{
    if(b==0)
    {
        x=1;
        y=0;
        return a;
    }
    ll r=exgcd(b,a%b,x,y);
    ll t=x;
    x=y;
    y=t-a/b*y;
    return r;
}

void cfunc(ll C[],ll x)
{
    ll xx,yy;
    C[0]=C[x]=1;
    for(ll i=1;i<x;i++)
    {
        ll t=(C[i-1]*(x-i+1))%mod;
        exgcd(i,(ll)mod,xx,yy);
        C[i]=((t*xx)%mod+mod)%mod;
    }
}
int main()
{
    //freopen("in.txt","r",stdin);
    while(~scanf("%d",&n))
    {
        cls(ca,0);
        cls(cb,0);
        cls(vis,0);
        int st,ed;
        for(int i=1;i<=n+1;i++)
        {
            scanf("%d",&num[i]);
            if(vis[num[i]]) ed=i;
            else vis[num[i]]=1;
        }
        for(int i=1;i<=n+1;i++)
        {
            if(num[i]==num[ed])
            {st=i;break;}
        }
        a=n+1;
        b=n+1-(ed-st+1);
        cfunc(ca,a);
        cfunc(cb,b);
        for(int i=1;i<=n+1;i++)
            printf("%lld\n",((ca[i]-cb[i-1])%mod+mod)%mod);
    }
    return 0;
}

 

转载于:https://www.cnblogs.com/mgz-/p/7119223.html

  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值