2017ccpc全国邀请赛(湖南湘潭) E. Partial Sum

E. Partial Sum
Bobo has a integer sequence a 1 ,a 2 ,...,a n of length n. Each time, he selects two ends 0 ≤ l < r ≤ n and
add |
∑ r
j=l+1 a j | − C into a counter which is zero initially. He repeats the selection for at most m times.
If each end can be selected at most once (either as left or right), find out the maximum sum Bobo may have.
Input
The input contains zero or more test cases and is terminated by end-of-file. For each test case:
The first line contains three integers n, m, C. The second line contains n integers a 1 ,a 2 ,...,a n .
• 2 ≤ n ≤ 10 5
• 1 ≤ 2m ≤ n + 1
• |a i |,C ≤ 10 4
• The sum of n does not exceed 10 6 .
Output
For each test cases, output an integer which denotes the maximum.
Sample Input
4 1 1
-1 2 2 -1
4 2 1
-1 2 2 -1
4 2 2
-1 2 2 -1
4 2 10
-1 2 2 -1
Sample Output
3
4
2
0

官方题解:

前缀和排下序,最大前缀和-最小前缀和就是最大区间和,一直枚举就行了

#include<cstdio>
#include<cstdlib>
#include<cstring>
#include<string>
#include<algorithm>
#include<iostream>
#include<queue>
#include<map>
#include<cmath>
#include<set>
#include<stack>
#define ll long long
#define max(x,y) (x)>(y)?(x):(y)
#define min(x,y) (x)>(y)?(y):(x)
#define cls(name,x) memset(name,x,sizeof(name))
using namespace std;
const int inf=1<<28;
const int maxn=100010;
const int maxm=110;
const int mod=1e9+7;
const double pi=acos(-1.0);
int n,m,c;
int num[maxn],sum[maxn];
int main()
{
    //freopen("in.txt","r",stdin);
    while(~scanf("%d%d%d",&n,&m,&c))
    {
        sum[0]=0;
        for(int i=1;i<=n;i++)
        {
            scanf("%d",&num[i]);
            sum[i]=sum[i-1]+num[i];
        }
        sort(sum,sum+n+1);
        ll ans=0;
        int l=0,r=n;
        for(int i=0;i<m&&l<r;i++)
        {
            if(sum[r]-sum[l]-c>=0)
            {
                ans+=sum[r]-sum[l]-c;
                r--,l++;
            }
        }
        printf("%I64d\n",ans);
    }
    return 0;
}

 

转载于:https://www.cnblogs.com/mgz-/p/6857933.html

  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值