AtCoder Regular Contest 081 E - Don't Be a Subsequence

E - Don't Be a Subsequence


Time limit : 2sec / Memory limit : 256MB

Score : 600 points

Problem Statement

A subsequence of a string S is a string that can be obtained by deleting zero or more characters from S without changing the order of the remaining characters. For example, arcartistic and (an empty string) are all subsequences of artisticabc and ci are not.

You are given a string A consisting of lowercase English letters. Find the shortest string among the strings consisting of lowercase English letters that are not subsequences of A. If there are more than one such string, find the lexicographically smallest one among them.

Constraints

  • 1≤|A|≤2×105
  • A consists of lowercase English letters.

Input

Input is given from Standard Input in the following format:

A

Output

Print the lexicographically smallest string among the shortest strings consisting of lowercase English letters that are not subsequences of A.


Sample Input 1

Copy
atcoderregularcontest

Sample Output 1

Copy
b

The string atcoderregularcontest contains a as a subsequence, but not b.


Sample Input 2

Copy
abcdefghijklmnopqrstuvwxyz

Sample Output 2

Copy
aa

Sample Input 3

Copy
frqnvhydscshfcgdemurlfrutcpzhopfotpifgepnqjxupnskapziurswqazdwnwbgdhyktfyhqqxpoidfhjdakoxraiedxskywuepzfniuyskxiyjpjlxuqnfgmnjcvtlpnclfkpervxmdbvrbrdn

Sample Output 3

Copy
aca


dp[i]代表[i~n]的子串的最小字典序串的长度
#include<cstdio>
#include<cstdlib>
#include<cstring>
#include<string>
#include<algorithm>
#include<iostream>
#include<queue>
#include<map>
#include<cmath>
#include<set>
#include<stack>
#define ll long long
#define pb push_back
#define max(x,y) ((x)>(y)?(x):(y))
#define min(x,y) ((x)>(y)?(y):(x))
#define cls(name,x) memset(name,x,sizeof(name))
#define fs first
#define sc second
#define mp make_pair
#define L(x) (1<<x)
#define next Next
using namespace std;
const int inf=1e9+10;
const ll llinf=1e16+10;
const int maxn=2e5+10;
const int maxm=1e3+10;
const int mod=1e9+7;
int n;
vector<int> v[30];
char s[maxn];
int dp[maxn];
int nch=26;
int querry(int pos,int ch)
{
    vector<int>::iterator it;
    it=lower_bound(v[ch].begin(),v[ch].end(),pos);
    if(it==v[ch].end()) return n;
    else return *it;
}
void solve()
{
    dp[n+1]=0;
    for(int i=n-1;i>=0;i--)
    {
        for(int j=0;j<nch;j++)
            dp[i]=min(dp[i],dp[querry(i,j)+1]+1);
    }
    int pos=0;
    while(pos<n)
    {
        for(int j=0;j<nch;j++)
        {
            int t=querry(pos,j)+1;
            if(dp[pos]==dp[t]+1)
            {
                printf("%c",j+'a');
                pos=t;
                break;
            }
        }
    }
    printf("\n");
}
int main()
{
    //freopen("in.txt","r",stdin);
    while(~scanf("%s",s))
    {
        for(int i=0;i<nch;i++)
            v[i].clear();
        n=strlen(s);
        for(int i=0;i<=n;i++)
            dp[i]=inf;
        for(int i=0;i<n;i++)
            v[s[i]-'a'].pb(i);
        solve();
    }
    return 0;
}

 

转载于:https://www.cnblogs.com/mgz-/p/7419263.html

  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值