Suppose a bank has K windows open for service. There is a yellow line in front of the windows which devides the waiting area into two parts. All the customers have to wait in line behind the yellow line, until it is his/her turn to be served and there is a window available. It is assumed that no window can be occupied by a single customer for more than 1 hour. Now given the arriving time T and the processing time P of each customer, you are supposed to tell the average waiting time of all the customers. Input Specification:Each input file contains one test case. For each case, the first line contains 2 numbers: N (≤104) - the total number of customers, and K (≤100) - the number of windows. Then N lines follow, each contains 2 times: Notice that the bank opens from 08:00 to 17:00. Anyone arrives early will have to wait in line till 08:00, and anyone comes too late (at or after 17:00:01) will not be served nor counted into the average. Output Specification:For each test case, print in one line the average waiting time of all the customers, in minutes and accurate up to 1 decimal place. |
Sample Input:
7 3
07:55:00 16
17:00:01 2
07:59:59 15
08:01:00 60
08:00:00 30
08:00:02 2
08:03:00 10
Sample Output:
8.2
题目大意
有K个窗口为客户办理业务,有N位客户需要办理业务,只要这位客户抵达时间早于等于17:00:00,就必须为其办理完业务,抵达晚于17:00:00的客户无需办理且不记录等待人数
求 : 总等待时间/等待人数,结果保留一位小数
思路
window[z]记录窗口z的最后结束工作时间,
所有窗口中最早结束的那个窗口记为当前时间
总等待时间 = 该人开始办理业务时间 - 该人抵达时间
C/C++
#include<bits/stdc++.h>
using namespace std;
int main()
{
set<pair<int,int>> line; // 抵达时间 + 办理业务所需时间
int N,K,window[101]={0},nowTime=28800,waitSum=0,hh,mm,ss,work,sum;
cin >> N >> K;
while (N--){
scanf("%d:%d:%d %d",&hh,&mm,&ss,&work);
sum = hh*3600+mm*60+ss;
work = min(work,60)*60;
if(sum<61201) line.insert({sum,work});
}
for(pair<int,int> x:line){
int key = 0;
for(int z=1;z<K;z++) {
if(window[z]<window[key]) {
key = z;
}
}
nowTime = max(window[key],nowTime);
if(nowTime<=x.first) window[key] = x.first+x.second;
else
{
waitSum += nowTime - x.first;
window[key] = nowTime + x.second;
}
}
printf("%.1f",waitSum*1.0/(line.size()*60));
return 0;
}