1035 Password

To prepare for PAT, the judge sometimes has to generate random passwords for the users. The problem is that there are always some confusing passwords since it is hard to distinguish 1 (one) from l (L in lowercase), or 0 (zero) from O (o in uppercase). One solution is to replace 1 (one) by @0 (zero) by %l by L, and O by o. Now it is your job to write a program to check the accounts generated by the judge, and to help the juge modify the confusing passwords.

Input Specification:

Each input file contains one test case. Each case contains a positive integer N (≤1000), followed by N lines of accounts. Each account consists of a user name and a password, both are strings of no more than 10 characters with no space.

Output Specification:

For each test case, first print the number M of accounts that have been modified, then print in the following M lines the modified accounts info, that is, the user names and the corresponding modified passwords. The accounts must be printed in the same order as they are read in. If no account is modified, print in one line There are N accounts and no account is modified where N is the total number of accounts. However, if N is one, you must print There is 1 account and no account is modified instead.


Sample Input 1:

3
Team000002 Rlsp0dfa
Team000003 perfectpwd
Team000001 R1spOdfa

Sample Output 1:

2
Team000002 RLsp%dfa
Team000001 R@spodfa

Sample Input 2:

1
team110 abcdefg332

Sample Output 2:

There is 1 account and no account is modified

Sample Input 3:

2
team110 abcdefg222
team220 abcdefg333

Sample Output 3:

There are 2 accounts and no account is modified

题目大意

给你 N 个人的账号根密码,要对该每个人的密码进行以下操作

数字     1 -> @
数字     0 -> %
小写的   l -> L
大写的   O -> o

如果该人有一个密码中有一个字符为 '1' '0' 'l' 'O',就嘚帮其换了,并记入替换的列表

结果根据是否存在需要替换的密码分别输出即可


思路

见代码


C/C++ 

#include<bits/stdc++.h>
using namespace std;
string OP(string password);
int main()
{
    string id,password;
    int N;
    vector<pair<string,string>> result;
    cin >> N;
    for(int z=0;z<N;z++){
        cin >> id >> password;
        password = OP(password);
        if(!password.empty()) result.emplace_back(id,password);
    }
    if(password.empty()){
        if(N==1) puts("There is 1 account and no account is modified");
        else printf("There are %d accounts and no account is modified",N);
    }else{
        cout << result.size() << endl;
        for(const auto& x:result) cout << x.first << ' ' << x.second << endl;
    }
    return 0;
}
string OP(string password)
{
    bool flag = true;
    for(char& x:password){
        if(x=='1') x='@',flag = false;
        if(x=='0') x='%',flag = false;
        if(x=='l') x='L',flag = false;
        if(x=='O') x='o',flag = false;
    }
    if(flag) return "";
    return password;
}

  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 打赏
    打赏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包

打赏作者

三块不一样的石头

十分满意,一分打赏~

¥1 ¥2 ¥4 ¥6 ¥10 ¥20
扫码支付:¥1
获取中
扫码支付

您的余额不足,请更换扫码支付或充值

打赏作者

实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值