1056 Mice and Rice

文章描述了一个名为MiceandRice的编程竞赛,参赛者需编写代码控制老鼠在地图上吃米,目标是成为最重的老鼠。比赛采用分组淘汰制,每组最多M只老鼠,最重的老鼠晋级。给定程序员的数量、每组的最大老鼠数、各老鼠的得分及出场顺序,程序需输出所有程序员的最终排名。提供的C++代码示例展示了如何计算每轮后的排名。
摘要由CSDN通过智能技术生成

Mice and Rice is the name of a programming contest in which each programmer must write a piece of code to control the movements of a mouse in a given map. The goal of each mouse is to eat as much rice as possible in order to become a FatMouse.

First the playing order is randomly decided for NP​ programmers. Then every NG​ programmers are grouped in a match. The fattest mouse in a group wins and enters the next turn. All the losers in this turn are ranked the same. Every NG​ winners are then grouped in the next match until a final winner is determined.

For the sake of simplicity, assume that the weight of each mouse is fixed once the programmer submits his/her code. Given the weights of all the mice and the initial playing order, you are supposed to output the ranks for the programmers.

Input Specification:

Each input file contains one test case. For each case, the first line contains 2 positive integers: NP​ and NG​ (≤1000), the number of programmers and the maximum number of mice in a group, respectively. If there are less than NG​ mice at the end of the player's list, then all the mice left will be put into the last group. The second line contains NP​ distinct non-negative numbers Wi​ (i=0,⋯,NP​−1) where each Wi​ is the weight of the i-th mouse respectively. The third line gives the initial playing order which is a permutation of 0,⋯,NP​−1 (assume that the programmers are numbered from 0 to NP​−1). All the numbers in a line are separated by a space.

Output Specification:

For each test case, print the final ranks in a line. The i-th number is the rank of the i-th programmer, and all the numbers must be separated by a space, with no extra space at the end of the line.


Sample Input:

11 3
25 18 0 46 37 3 19 22 57 56 10
6 0 8 7 10 5 9 1 4 2 3

Sample Output:

5 5 5 2 5 5 5 3 1 3 5


题目大意

老鼠吃米得分比赛,每个选手(0~N-1编号)操作老鼠吃米得分,并按照给定顺序出场。

每一轮中,每M人一组,最后若不足M人也仍为一组;

每组得分最高的晋级,其余淘汰,且并列排名为本仑晋级人数+1

给你俩个数N和M,分别表示参赛选手与每组人数

再按编号0~N-1给你每个选手得分

最后给你出场顺序求解


思路

经典队列,每轮剩余人数为key,每组M人,那么每轮就有 "key/M + (key%M!=0)" 组,

淘汰的人排名rank =  key/M + (key%M==0?1:2)


C/C++ 

#include<iostream>
#include<queue>
using namespace std;
int power[1001],ranking[1001];
int riseRank(queue<int> *list,int N,int rank);
int main()
{
    queue<int> list;
    int N,M,num;
    cin >> N >> M;
    for(int z=0;z<N;z++){
        cin >> power[z];
    }
    for(int z=0;z<N;z++){
        cin >> num;
        list.push(num);
    }
    while (list.size()>1){
        int key = list.size();
        int rank = key/M + (key%M==0?1:2);
        while (key>M){
            list.push(riseRank(&list,M,rank));
            key -= M;
        }
        if(key>0) {
            list.push(riseRank(&list, key,rank));
        }
    }
    ranking[list.front()] = 1;
    cout << ranking[0];
    for(int z=1;z<N;z++) cout << " " << ranking[z];
    return 0;
}

int riseRank(queue<int> *list,int N,int rank)
{
    int maxNum = list->front();
    list->pop();
    for(int z=1;z<N;z++){
        if(power[list->front()] > power[maxNum]){
            ranking[maxNum] = rank;
            maxNum = list->front();
        }else{
            ranking[list->front()] = rank;
        }
        list->pop();
    }
    return maxNum;
}



  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 打赏
    打赏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包

打赏作者

三块不一样的石头

十分满意,一分打赏~

¥1 ¥2 ¥4 ¥6 ¥10 ¥20
扫码支付:¥1
获取中
扫码支付

您的余额不足,请更换扫码支付或充值

打赏作者

实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值