1059 Prime Factors

Given any positive integer N, you are supposed to find all of its prime factors, and write them in the format N = p1​k1​×p2​k2​×⋯×pm​km​.

Input Specification:

Each input file contains one test case which gives a positive integer N in the range of long int.

Output Specification:

Factor N in the format N = p1​^k1​*p2​^k2​**pm​^km​, where pi​'s are prime factors of N in increasing order, and the exponent ki​ is the number of pi​ -- hence when there is only one pi​, ki​ is 1 and must NOT be printed out.


Sample Input:

97532468

Sample Output:

97532468=2^2*11*17*101*1291

题目大意

给你一个正整数,你要用其素数因子组合成如上所述的式子,并使其值与该正整数相同

要求:尽可能的使用较小的素数因子

注意输入为1时,输出为 1 = 1 (测试点3)


思路

先打一个素数表,然后逐个判断过来即可


C/C++ 

#include<iostream>
using namespace std;
int main()
{
    bool apr[202322];
    int prime[202322],N=0;
    for(int z=2;z<202322;z++){
        if(!apr[z]){
            prime[N++] = z;
            long key = z;
            while(key<202322){
                apr[z] = true;
                key+=z;
            }
        }
    }

    long num,output=0;
    cin >> num;
    cout << num << "=";
    if(num==1) cout << 1;
    for(int z=0;num!=0 && z<N;z++){
        long key = 0;
        while(num!=0 && num%prime[z]==0){
            num /= prime[z];
            key++;
        }
        if(key>0){
            if(output) cout << "*";
            if(key==1) cout << prime[z];
            else printf("%ld^%ld",prime[z],key);
            output = 1;
        }
    }

    return 0;
}


  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 打赏
    打赏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包

打赏作者

三块不一样的石头

十分满意,一分打赏~

¥1 ¥2 ¥4 ¥6 ¥10 ¥20
扫码支付:¥1
获取中
扫码支付

您的余额不足,请更换扫码支付或充值

打赏作者

实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值