Description |
从键盘读取一组整数,分别输出这组整数中正整数和负整数的累加和.其中第一个数为这组数的个数. |
Input |
输入一组整数,其中第一个数为这组数的个数。各数之间用空格隔开。 |
Output |
分别输出这组数中正数的累加和,以及负数的累加和。 |
Sample Input |
5 -1 3 -4 6 1 3 2 4 6 |
Sample Output |
positive sum=10 negtive sum=-5 positive sum=12 negtive sum=0 |
import java.util.Scanner;
public class Main {
public static void main(String args[])
{
int count = 0;
int num=0;
int a;
int b;
int i;
Scanner input = new Scanner(System.in);
while(input.hasNext()){
int n = input.nextInt();
count=0;
num=0;
for(i=0;i<n;i++)
{
b=input.nextInt();
if(b>0)
{
num+=b;
}
if(b<0)
{
count+=b;
}
}
System.out.printf("positive sum=%d\n",num);
System.out.printf("negtive sum=%d\n",count);
}
}
}