ZOJ Problem Set–1879 Jolly Jumpers

Time Limit: 2 Seconds      Memory Limit: 65536 KB


A sequence of n > 0 integers is called a jolly jumper if the absolute values of the difference between successive elements take on all the values 1 through n-1. For instance,

1 4 2 3

is a jolly jumper, because the absolutes differences are 3, 2, and 1 respectively. The definition implies that any sequence of a single integer is a jolly jumper. You are to write a program to determine whether or not each of a number of sequences is a jolly jumper.

Input
Each line of input contains an integer n < 3000 followed by n integers representing the sequence.

Output

For each line of input, generate a line of output saying "Jolly" or "Not jolly".

Sample Input
4 1 4 2 3
5 1 4 2 -1 6

Sample Output
Jolly
Not jolly


Source: University of Waterloo Local Contest 2000.09.30

 
 
#include<iostream>
#include<set>
using namespace std;
 
 
int main(void)
{
  int n;
  while(cin>>n)
  {
    set<int> s;
    for(int i = 1;i < n; i++)
      s.insert(i);
    int preInteger = 0;
    int number;
    for(int j = 0; j < n; j++)
    {
      cin>>number;
      if(j != 0)
      {
        int integerInSet = (number - preInteger > 0 ? number - preInteger:preInteger - number);
        if(s.find(integerInSet) != s.end())
        {
          s.erase(integerInSet);
        }
      }
      preInteger = number;
    }
    if(s.size() == 0)
    {
      cout<<"Jolly";
    }
    else
    {
      cout<<"Not jolly";
    }
    cout<<endl;
  }
  return 0;
}

转载于:https://www.cnblogs.com/malloc/archive/2012/05/08/2490276.html

评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值