HDU 3123 GCC

Problem Description

The GNU Compiler Collection (usually shortened to GCC) is a compiler system produced by the GNU Project supporting various programming languages. But it doesn’t contains the math operator “!”.
In mathematics the symbol represents the factorial operation. The expression n! means "the product of the integers from 1 to n". For example, 4! (read four factorial) is 4 × 3 × 2 × 1 = 24. (0! is defined as 1, which is a neutral element in multiplication, not multiplied by anything.)
We want you to help us with this formation: (0! + 1! + 2! + 3! + 4! + ... + n!)%m

Input

The first line consists of an integer T, indicating the number of test cases.
Each test on a single consists of two integer n and m.

Output

Sample Input

1
10 861017

Sample Output

593846
思路:当n!大于等于m的时候,肯定可以整除m,所以我们只需要计算n!<m
#include <iostream>
#include<cstdio>
#include<cstring>
using namespace std;

int main()
{
   int icase;
   int m;
   char n[105];
   scanf("%d",&icase);
   while(icase--)
   {
       scanf("%s %d",n,&m);
       int num,t;
       if(strlen(n)>=7)  //m的最大数值对应的长度
          t=m;
       else
          sscanf(n,"%d",&t);

        long long mid=1,sum=1;

        for(int i=1;i<=t;i++)
        {
            mid=((mid%m)*(i%m))%m;    //计算阶乘
            sum=(sum%m+mid%m)%m;       //阶乘的相加
        }
        printf("%lld\n",sum%m);

   }
    return 0;
}


  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值