POJ 3181 Dollar Dayz (完全背包 + 大数分离输出)

Farmer John goes to Dollar Days at The Cow Store and discovers an unlimited number of tools on sale. During his first visit, the tools are selling variously for $1, $2, and $3. Farmer John has exactly $5 to spend. He can buy 5 tools at $1 each or 1 tool at $3 and an additional 1 tool at $2. Of course, there are other combinations for a total of 5 different ways FJ can spend all his money on tools. Here they are: 


        1 @ US$3 + 1 @ US$2


        1 @ US$3 + 2 @ US$1


        1 @ US$2 + 3 @ US$1


        2 @ US$2 + 1 @ US$1


        5 @ US$1
Write a program than will compute the number of ways FJ can spend N dollars (1 <= N <= 1000) at The Cow Store for tools on sale with a cost of $1..$K (1 <= K <= 100).
Input
A single line with two space-separated integers: N and K.
Output
A single line with a single integer that is the number of unique ways FJ can spend his money.
Sample Input
5 3
Sample Output

5

题意:可以有多少种方法使从1--k的数字中挑选任意的数字任意个构成n

思路:完全背包,但是此题目的数据太大,用long long也无法直接输出,那么我们采用大数分离的方法存储并输出

思路来源:http://www.hankcs.com/program/cpp/poj-3181-dollar-dayz.html

大数分离的方法:

1.用long long类型  存储数据比 int存储的位数更多 long long 类型为1.8e19 所以我们一个数组只存18位,留一位做进位处理,防止溢出

2.高位的计算+对低位进位

 低位的计算

#include <iostream>
#include <cstdio>
#include <map>
#include <cstring>
#include <string>
#include <algorithm>
#include <cmath>
#include <set>

using namespace std;
typedef long long ll;//ll Ϊ 1.8e19
const ll INF = 1e18;
const int N = 1e3+10;
ll dp1[N];
ll dp2[N];
int main()
{
    int n,k;
    scanf("%d%d",&n,&k);
        memset(dp1,0,sizeof(dp1));
        memset(dp2,0,sizeof(dp2));
        dp2[0]=1;
        for(int i=1;i<=k;i++)
          for(int j=i;j<=n;j++){
          dp1[j]=(dp1[j]+dp1[j-i])+(dp2[j]+dp2[j-i])/INF;  //高位 从后往前 19--36位  
          dp2[j]=(dp2[j]+dp2[j-i])%INF;   //低位 从后往前1--18位
          }
        if(dp1[n])
        printf("%lld",dp1[n]);
        printf("%lld\n",dp2[n]);
    return 0;
}


评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值