HDU - 1541 Stars 树状数组 单点更新(求比当前数字大的数字有多少个)

Astronomers often examine star maps where stars are represented by points on a plane and each star has Cartesian coordinates. Let the level of a star be an amount of the stars that are not higher and not to the right of the given star. Astronomers want to know the distribution of the levels of the stars. 


For example, look at the map shown on the figure above. Level of the star number 5 is equal to 3 (it's formed by three stars with a numbers 1, 2 and 4). And the levels of the stars numbered by 2 and 4 are 1. At this map there are only one star of the level 0, two stars of the level 1, one star of the level 2, and one star of the level 3. 


You are to write a program that will count the amounts of the stars of each level on a given map.
Input
The first line of the input file contains a number of stars N (1<=N<=15000). The following N lines describe coordinates of stars (two integers X and Y per line separated by a space, 0<=X,Y<=32000). There can be only one star at one point of the plane. Stars are listed in ascending order of Y coordinate. Stars with equal Y coordinates are listed in ascending order of X coordinate.
Output
The output should contain N lines, one number per line. The first line contains amount of stars of the level 0, the second does amount of stars of the level 1 and so on, the last line contains amount of stars of the level N-1.
Sample Input
5
1 1
5 1
7 1
3 3
5 5
Sample Output
1
2
1
1

0

题意:给出n个点的坐标,y轴坐标是升序排列的,输出大于0--n-1个的坐标等级各有多少个,大于的标准是一个点的x,y轴上的坐标大于等于另一个点。

思路:y轴坐标是升序排列的,所以我们只需要比较x的即可,此题目就和HDU 1394的单点更新类似了

注意树状数组处理不了0的情况,所以要将计算数字+1处理

#include <iostream>
#include <cstdio>
#include <cstring>
#include <string>
#include <algorithm>
#include <map>
#include <set>
#include <cmath>
using namespace std;
typedef long long ll;
const int N = 32005;
int n;
int ans[N];  //结果数组
int c[N];    //
int lowbit(int k)
{
    return k&-k;
}
int getsum(int en)
{
    int re=0;
    while(en>0)
    {
        re+=c[en];
        en-=lowbit(en);
    }
    return re;
}
void update(int pos,int d)
{
    while(pos<=N)
    {
        c[pos]+=d;
        pos+=lowbit(pos);
    }
}
int main()
{
    while(scanf("%d",&n)==1)
    {   
        int x,y;
        memset(ans,0,sizeof(ans));
        memset(c,0,sizeof(c));
        for(int i=1;i<=n;i++)
        {
            scanf("%d%d",&x,&y);
            x++;
            ans[getsum(x)]++;
            update(x,1);
        }
        for(int i=0;i<n;i++)
        printf("%d\n",ans[i]);
    }
}

  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值