POJ - 3349 Snowflake Snow Snowflakes hash 判断六角是否相同

You may have heard that no two snowflakes are alike. Your task is to write a program to determine whether this is really true. Your program will read information about a collection of snowflakes, and search for a pair that may be identical. Each snowflake has six arms. For each snowflake, your program will be provided with a measurement of the length of each of the six arms. Any pair of snowflakes which have the same lengths of corresponding arms should be flagged by your program as possibly identical.

Input
The first line of input will contain a single integer n, 0 < n ≤ 100000, the number of snowflakes to follow. This will be followed by n lines, each describing a snowflake. Each snowflake will be described by a line containing six integers (each integer is at least 0 and less than 10000000), the lengths of the arms of the snow ake. The lengths of the arms will be given in order around the snowflake (either clockwise or counterclockwise), but they may begin with any of the six arms. For example, the same snowflake could be described as 1 2 3 4 5 6 or 4 3 2 1 6 5.

Output
If all of the snowflakes are distinct, your program should print the message:
No two snowflakes are alike.
If there is a pair of possibly identical snow akes, your program should print the message:
Twin snowflakes found.

Sample Input
2
1 2 3 4 5 6
4 3 2 1 6 5
Sample Output
Twin snowflakes found.

题意:给出n个雪花,雪花有6个角,判断是否存在完全相同(6个角的大小完全相同且顺序一直)的两片。

思路:hash(a1,a2,a3,a4,a6)mod  P,P是一个较大的质数,对于两片相同的雪花,他们的六个角的长度之积,长度之和完全相同,所以hash函数值也相同。

建立了一个hash表,N片雪花依次插入,对于每片雪花直接扫描表头对应的链表,检查是否有完全一样的。对于随机数据,时间复杂度为O(N*N/P),取P最接近N的质数。

#include <iostream>
#include <cstdio>
#include <cstring>
#include <string>
#include <algorithm>
#include <map>
#include <set>
#include <cmath>
#include <queue>
const int MAXN=1e5+5;
const int P=99991;
typedef long long ll;
using namespace std;
int n,cnt=0;
int snow[MAXN][6];
int head[MAXN];
int nex[MAXN];
int H(int *a)
{
    int sum=0,mul=1;
    for(int i=0;i<6;i++){
        sum=(sum+a[i])%P;
        mul=(ll)mul*a[i]%P;
    }
    return (sum+mul)%P;
}
bool judge(int *a,int *b)
{
    for(int i=0;i<6;i++){
        for(int j=0;j<6;j++){
            bool flag=1;
            for(int k=0;k<6;k++)
                if(a[(i+k)%6]!=b[(j+k)%6])
                    flag=0;
            if(flag)
                return 1;
            flag=1;
            for(int k=0;k<6;k++)
                if(a[(i+k)%6]!=b[(j-k+6)%6])
                    flag=0;
            if(flag)
                return 1;
        }
    }
    return 0;
}
bool iinsert(int *a)
{
    int val=H(a);
    //cout<<val<<endl;
    for(int i=head[val];i;i=nex[i]){
        int num=judge(snow[i],a);
        /*for(int j=0;j<6;j++)
            printf("%d ",snow[i][j]);*/
        if(num)
           return 1;

    }
    ++cnt;
    memcpy(snow[cnt],a,6*sizeof(int));
    nex[cnt]=head[val];
    head[val]=cnt;
    return 0;
}
int main()
{
   cin>>n;
   for(int i=1;i<=n;i++){
    int a[10];
    for(int j=0;j<6;j++)
        scanf("%d",&a[j]);
     if(iinsert(a)){
        puts("Twin snowflakes found.");
        return 0;
    }
   }
   puts("No two snowflakes are alike.");
}

 

  • 0
    点赞
  • 1
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值