HDU 6342 Expression in Memories 表达式填充

31 篇文章 1 订阅
25 篇文章 1 订阅

Kazari remembered that she had an expression s0 before.
Definition of expression is given below in Backus–Naur form.
<expression> ::= <number> | <expression> <operator> <number>
<operator> ::= "+" | "*"
<number> ::= "0" | <non-zero-digit> <digits>
<digits> ::= "" | <digits> <digit>
<digit> ::= "0" | <non-zero-digit>
<non-zero-digit> ::= "1" | "2" | "3" | "4" | "5" | "6" | "7" | "8" | "9"
For example, `1*1+1`, `0+8+17` are valid expressions, while +1+1, +1*+1, 01+001 are not.
Though s0 has been lost in the past few years, it is still in her memories. 
She remembers several corresponding characters while others are represented as question marks.
Could you help Kazari to find a possible valid expression s0 according to her memories, represented as s, by replacing each question mark in s with a character in 0123456789+* ?

Input

The first line of the input contains an integer T denoting the number of test cases.
Each test case consists of one line with a string s (1≤|s|≤500,∑|s|≤105).
It is guaranteed that each character of s will be in 0123456789+*? .

Output

For each test case, print a string s0 representing a possible valid expression.
If there are multiple answers, print any of them.
If it is impossible to find such an expression, print IMPOSSIBLE.

Sample Input
5
?????
0+0+0
?+*??
?0+?0
?0+0?
 

Sample Output
11111
0+0+0
IMPOSSIBLE
10+10
IMPOSSIBLE

题意:?可以替代任何字符和数字,判断字符串是否符合正常的加乘法运算,且数字不可以出现先导0

思路:对于  +0?  形式 已经0? (0为开头) 这些情况的?变为+,其余的均为1

#include <iostream>
#include <cstdio>
#include <cstring>
#include <string>
#include <algorithm>
#include <map>
#include <set>
#include <cmath>
using namespace std;
typedef long long ll;
const int N = 1005;
char a[N];
int main()
{
    int t;
    scanf("%d",&t);
    while(t--){
        scanf("%s",a);
        int len=strlen(a);
        for(int i=0;i<len;i++){
            if(a[i]=='+'&&a[i+1]=='0'&&a[i+2]=='?')
                a[i+2]='+';
            else if(a[i]=='*'&&a[i+1]=='0'&&a[i+2]=='?')
                a[i+2]='+';
            else if(a[i]=='?')
                a[i]='1';
            if(a[0]=='0'&&a[1]=='?')
                a[1]='+';
        }
        int flag=0;
        for(int i=0;i<len;i++){
            if((a[i]=='*'||a[i]=='+')&&(a[i+1]=='*'||a[i+1]=='+'))
             {
                 flag=1;
                 break;
             }
             if((a[i]=='*'||a[i]=='+')&&a[i+1]=='0'&&'0'<=a[i+2]&&a[i+2]<='9')
             {
                 flag=1;
                 break;
             }
             if(a[0]=='*'||a[0]=='+'){
                flag=1;
                break;
             }
             if(a[len-1]=='*'||a[len-1]=='+'){
                flag=1;
                break;
             }
             if(a[0]=='0'&&'0'<=a[1]&&a[1]<='9'){
                flag=1;
                break;
             }
        }
        if(flag)
            printf("IMPOSSIBLE\n");
        else{
            printf("%s\n",a);
        }
    }
    return 0;
}

 

评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值