POJ 3190 -Stall Reservations 小根堆 贪心 区间问题

23 篇文章 0 订阅
2 篇文章 0 订阅

Oh those picky N (1 <= N <= 50,000) cows! They are so picky that each one will only be milked over some precise time interval A..B (1 <= A <= B <= 1,000,000), which includes both times A and B. Obviously, FJ must create a reservation system to determine which stall each cow can be assigned for her milking time. Of course, no cow will share such a private moment with other cows. 

Help FJ by determining:
The minimum number of stalls required in the barn so that each cow can have her private milking period
An assignment of cows to these stalls over time
Many answers are correct for each test dataset; a program will grade your answer.
Input
Line 1: A single integer, N 

Lines 2..N+1: Line i+1 describes cow i's milking interval with two space-separated integers.
Output
Line 1: The minimum number of stalls the barn must have. 

Lines 2..N+1: Line i+1 describes the stall to which cow i will be assigned for her milking period.
Sample Input
5
1 10
2 4
3 6
5 8
4 7
Sample Output
4
1
2
3
2
4
Hint
Explanation of the sample: 

Here's a graphical schedule for this output: 

Time     1  2  3  4  5  6  7  8  9 10

Stall 1 c1>>>>>>>>>>>>>>>>>>>>>>>>>>>

Stall 2 .. c2>>>>>> c4>>>>>>>>> .. ..

Stall 3 .. .. c3>>>>>>>>> .. .. .. ..

Stall 4 .. .. .. c5>>>>>>>>> .. .. ..
Other outputs using the same number of stalls are possible.

题意:N头牛在房子吃草,每个房子一段时间只能供一头牛吃草,求所有的牛吃草最少需要多少个房子,且输出牛与对应的房子编号

思路:贪心 对于每一头牛,先按照开始吃草的时间排序,扫描满足当前吃草的牛开始吃草的时间不早于最后一头牛吃草结束的时间,如果这样的房子不存在则新建一个,可以使用小根堆来维护每个房子最后一头牛吃草的结束时间,尝试把当前的牛安排在堆顶,小根堆的时间复杂度O(log N)

#include <iostream>
#include <cstdio>
#include <cstring>
#include <string>
#include <algorithm>
#include <map>
#include <set>
#include <cmath>
#include <queue>
using namespace std;
typedef long long ll;
const int N = 5e4+5;
struct node
{
    int s;
    int e;
    int id;
    friend  bool operator<(node a,node b)
    {
        return a.e>b.e;
    }
}a[N];
int t[N];
bool cmp(node a,node b)
{
    return a.s<b.s;
}
int main()
{
    int n;
    while(scanf("%d",&n)==1){
        for(int i=0;i<n;i++){
            scanf("%d%d",&a[i].s,&a[i].e);
            a[i].id=i;
        }
        memset(t,0,sizeof(t));
        sort(a,a+n,cmp);
        priority_queue<node> que;//优先队列+自定义
        int num=0;
        que.push(a[0]);
        t[a[0].id]=++num;
        for(int i=1;i<n;i++){
            node now=que.top();
            if(now.e<a[i].s){
                t[a[i].id]=t[now.id];
                que.pop();
                que.push(a[i]);
            }
            else{
                t[a[i].id]=++num;
                que.push(a[i]);
            }
        }
        cout<<num<<endl;
        for(int i=0;i<n;i++)
            printf("%d\n",t[i]);
    }

    return 0;
}

 

  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值