District Division

Time Limit: 1 Second      Memory Limit: 65536 KB      Special Judge


Ezio learned a lot from his uncle Mario in Villa Auditore. He also made some contribution to Villa Auditore. One of the contribution is dividing it into many small districts for convenience of management. If one district is too big, person in control of this district would feel tiring to keep everything in order. If one district is too small, there would be too many districts, which costs more to set manager for each district.

There are n rooms numbered from 1 to n in Villa Auditore and (n−1) corridors connecting them. Let's consider each room as a node and each corridor connecting two rooms as an edge. By coincidence, Villa Auditore forms a tree.

Ezio wanted the size of each district to be exactly k, which means there should be exactly k rooms in one district. Each room in one district should have at least one corridor directly connected to another room in the same district, unless there are only one room in this district (that is to say, the rooms in the same district form a connected component). It's obvious that Villa Auditore should be divided into n/k districts.

Now Ezio was wondering whether division can be done successfully.

Input

There are multiple test cases. The first line of the input contains an integer T (about 10000), indicating the number of cases. For each test case:

The first line contains two integers n, k (1≤n≤10e5, 1≤k≤n), indicating the number of rooms in Vally Auditore and the number of rooms in one district.

The following (n−1) lines each contains two integers ai, bi (1≤ai,bi≤n), indicating a corrider connecting two rooms ai and bi.

It's guaranteed that:

  • n is a multiple of k;
  • The given graph is a tree;
  • The sum of n in all test cases will not exceed 10e6.

Output

For each test case:

  • If the division can be done successfully, output "YES" (without quotes) in the first line. Then output nk lines each containing k integers seperated by one space, indicating a valid division plan. If there are multiple valid answers, print any of them.
  • If the division cannot be done successfully, output "NO" (without quotes) in the first line.

Please, DO NOT output extra spaces at the end of each line, or your answer will be considered incorrect!

Sample Input

3

4 2

1 3

3 2

1 4

6 3

1 3

1 4

1 6

2 5

5 1

8 4

1 2

2 3

2 4

1 5

5 6

5 7

5 8

Sample Output

YES

1 4

2 3

NO

YES

4 3 2 1

5 6 7 8

大致题意就是说给你结点数为一个树,要你判断一下可不可以分成一些子树,使这些子树的结点个数均为k;递归计算所有子树的结点数,如果所有子树中结点数可以被k整除的子树个数为n/k,则可以,然后再输出各个子树的结点编号即可。不足n/k的就不能分成。

#include <bits/stdc++.h>
using namespace std;
struct tree
{
    int n;
    vector<int> a;
};
tree A[100005];
int B[100005];
bool vis[100005];
bool L[100005],R[100005];
int findi(int i)
{
    if(!vis[i])
    {
        vis[i]=true;
        int t=1;
        for(int j=0;j<A[i].a.size();j++)
        {
            if(!vis[A[i].a[j]])
            t+=findi(A[i].a[j]);
        }
        return A[i].n=t;
    }
    return A[i].n;
}
int main()
{
    int t,n,k;
    int j,i,l,a,b;
    scanf("%d",&t);
    while(t--)
    {
        scanf("%d%d",&n,&k);
        for(i=0;i<=n;i++){
            A[i].n=0;
            A[i].a.clear();
        }
        for(i=1;i<n;i++)
        {
            scanf("%d%d",&a,&b);
            A[a].a.push_back(b);
            A[b].a.push_back(a);
        }
        memset(vis,false,sizeof(vis));
        A[1].n=findi(1);
        l=n/k;
        j=0;
        for(i=1;i<=n;i++)
        {
            if(A[i].n%k==0)
            {
                B[j++]=i;
            }
        }
        //cout<<j<<' '<<l<<endl;
        if(j==l)
        {
            printf("YES\n");
            memset(vis,false,sizeof(vis));
            for(i=0;i<j;i++)
            {
                queue<int> T;
                T.push(B[i]);
                vis[B[i]]=true;
                while(!T.empty())
                {
                    a=T.front();
                    T.pop();
                    for(l=0;l<A[a].a.size();l++)
                    {
                        if((A[A[a].a[l]].n%k!=0)&&!vis[A[a].a[l]])
                        {
                            vis[A[a].a[l]]=true;
                            T.push(A[a].a[l]);
                        }
                    }
                    printf("%d",a);
                    if(!T.empty()) printf(" ");
                    else printf("\n");
                }
            }
        }
        else printf("NO\n");
    }
    return 0;
}

 

转载于:https://www.cnblogs.com/shadowlink/p/9167931.html

  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
东南亚位于我国倡导推进的“一带一路”海陆交汇地带,作为当今全球发展最为迅速的地区之一,近年来区域内生产总值实现了显著且稳定的增长。根据东盟主要经济体公布的最新数据,印度尼西亚2023年国内生产总值(GDP)增长5.05%;越南2023年经济增长5.05%;马来西亚2023年经济增速为3.7%;泰国2023年经济增长1.9%;新加坡2023年经济增长1.1%;柬埔寨2023年经济增速预计为5.6%。 东盟国家在“一带一路”沿线国家中的总体GDP经济规模、贸易总额与国外直接投资均为最大,因此有着举足轻重的地位和作用。当前,东盟与中国已互相成为双方最大的交易伙伴。中国-东盟贸易总额已从2013年的443亿元增长至 2023年合计超逾6.4万亿元,占中国外贸总值的15.4%。在过去20余年中,东盟国家不断在全球多变的格局里面临挑战并寻求机遇。2023东盟国家主要经济体受到国内消费、国外投资、货币政策、旅游业复苏、和大宗商品出口价企稳等方面的提振,经济显现出稳步增长态势和强韧性的潜能。 本调研报告旨在深度挖掘东南亚市场的增长潜力与发展机会,分析东南亚市场竞争态势、销售模式、客户偏好、整体市场营商环境,为国内企业出海开展业务提供客观参考意见。 本文核心内容: 市场空间:全球行业市场空间、东南亚市场发展空间。 竞争态势:全球份额,东南亚市场企业份额。 销售模式:东南亚市场销售模式、本地代理商 客户情况:东南亚本地客户及偏好分析 营商环境:东南亚营商环境分析 本文纳入的企业包括国外及印尼本土企业,以及相关上下游企业等,部分名单 QYResearch是全球知名的大型咨询公司,行业涵盖各高科技行业产业链细分市场,横跨如半导体产业链(半导体设备及零部件、半导体材料、集成电路、制造、封测、分立器件、传感器、光电器件)、光伏产业链(设备、硅料/硅片、电池片、组件、辅料支架、逆变器、电站终端)、新能源汽车产业链(动力电池及材料、电驱电控、汽车半导体/电子、整车、充电桩)、通信产业链(通信系统设备、终端设备、电子元器件、射频前端、光模块、4G/5G/6G、宽带、IoT、数字经济、AI)、先进材料产业链(金属材料、高分子材料、陶瓷材料、纳米材料等)、机械制造产业链(数控机床、工程机械、电气机械、3C自动化、工业机器人、激光、工控、无人机)、食品药品、医疗器械、农业等。邮箱:market@qyresearch.com
东南亚位于我国倡导推进的“一带一路”海陆交汇地带,作为当今全球发展最为迅速的地区之一,近年来区域内生产总值实现了显著且稳定的增长。根据东盟主要经济体公布的最新数据,印度尼西亚2023年国内生产总值(GDP)增长5.05%;越南2023年经济增长5.05%;马来西亚2023年经济增速为3.7%;泰国2023年经济增长1.9%;新加坡2023年经济增长1.1%;柬埔寨2023年经济增速预计为5.6%。 东盟国家在“一带一路”沿线国家中的总体GDP经济规模、贸易总额与国外直接投资均为最大,因此有着举足轻重的地位和作用。当前,东盟与中国已互相成为双方最大的交易伙伴。中国-东盟贸易总额已从2013年的443亿元增长至 2023年合计超逾6.4万亿元,占中国外贸总值的15.4%。在过去20余年中,东盟国家不断在全球多变的格局里面临挑战并寻求机遇。2023东盟国家主要经济体受到国内消费、国外投资、货币政策、旅游业复苏、和大宗商品出口价企稳等方面的提振,经济显现出稳步增长态势和强韧性的潜能。 本调研报告旨在深度挖掘东南亚市场的增长潜力与发展机会,分析东南亚市场竞争态势、销售模式、客户偏好、整体市场营商环境,为国内企业出海开展业务提供客观参考意见。 本文核心内容: 市场空间:全球行业市场空间、东南亚市场发展空间。 竞争态势:全球份额,东南亚市场企业份额。 销售模式:东南亚市场销售模式、本地代理商 客户情况:东南亚本地客户及偏好分析 营商环境:东南亚营商环境分析 本文纳入的企业包括国外及印尼本土企业,以及相关上下游企业等,部分名单 QYResearch是全球知名的大型咨询公司,行业涵盖各高科技行业产业链细分市场,横跨如半导体产业链(半导体设备及零部件、半导体材料、集成电路、制造、封测、分立器件、传感器、光电器件)、光伏产业链(设备、硅料/硅片、电池片、组件、辅料支架、逆变器、电站终端)、新能源汽车产业链(动力电池及材料、电驱电控、汽车半导体/电子、整车、充电桩)、通信产业链(通信系统设备、终端设备、电子元器件、射频前端、光模块、4G/5G/6G、宽带、IoT、数字经济、AI)、先进材料产业链(金属材料、高分子材料、陶瓷材料、纳米材料等)、机械制造产业链(数控机床、工程机械、电气机械、3C自动化、工业机器人、激光、工控、无人机)、食品药品、医疗器械、农业等。邮箱:market@qyresearch.com

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值