1059 Prime Factors (25分)

Given any positive integer N, you are supposed to find all of its prime factors, and write them in the format N = p
​1
​​
​k
​1
​​
​​ ×p
​2
​​
​k
​2
​​
​​ ×⋯×p
​m
​​
​k
​m
​​
​​ .

Input Specification:
Each input file contains one test case which gives a positive integer N in the range of long int.

Output Specification:
Factor N in the format N = p
​1
​​ ^k
​1
​​ *p
​2
​​ ^k
​2
​​ *…*p
​m
​​ ^k
​m
​​ , where p
​i
​​ 's are prime factors of N in increasing order, and the exponent k
​i
​​ is the number of p
​i
​​ – hence when there is only one p
​i
​​ , k
​i
​​ is 1 and must NOT be printed out.

Sample Input:
97532468
Sample Output:
97532468=2^2*11*17*101*1291

第一次写质因数分解的题目,碰到这种题,做两件事,一件是保存素数表,第二件是质因数分解。
保存素数表,long int不小于int,而根号int的最大不超过50000,所以开个100000的数组(抄算法笔记的),函数find_prime(),从1到maxn遍历,判断i是否为素数,如果是就将其加入素数表中,记得定义一个全局num记录素数表当前个数。
判断是否为素数,老生常谈。如果为1就return false,sqrt函数返回的是double类型,强制转换为int,从2遍历到Sqrt,Sqrt也要取,如果n%i为0就return false。
然后是质因数分解,因为要记录质因数的指数,所以定义factor结点,里面分别存了值和指数,开一个存10个factor的数组就可以了,因为最小的连续10个素数相乘都超过int了。遍历素数表,循环条件为i<num &&当前素数小于sqrt(n),这个n是初始的n,因为n为一直变化,为什么有个条件是小于sqrt(n),因为n的质因数中要不就全小于sqrt(n),要不就有一个大于sqrt(n),其余全小于(自己想想为啥)。如果n%当前素数余数为0,就将当前素数加入fac数组中,记得有一个fnum记录质因数个数,并将其的cnt设为0。再对n进行循环,while(n%当前素数 == 0),就一直对当前fac的cnt++,并将n /= 当前素数。
循环完后,可能n不等于1,那么就最后一个质因数就是n本身(就是那个大于sqrt(n))的数,将其加入fac。
最后输出fac即可

#include<cstdio>
#include<cmath>
#include<iostream>
using namespace std;
const int maxn = 100010;
int prime[maxn];//素数表
int num = 0;//记录每个素数在表中的位置
int n;//目标值
struct factor{
    int x, cnt;
}fac[10];//最小的10个素数相乘都超过int了,所以最大只需要开10个

bool isPrime(int n){
    if(n == 1) return false;
    int Sqrt = (int)sqrt(n);
    for(int i = 2; i <= Sqrt; i++){
        if(n % i == 0) return false;
    }
    return true;
}

void find_prime(){
    for(int i = 1; i < maxn; i++){
        if(isPrime(i)){
            prime[num++] = i;
        }
    }
}
int main(){
    find_prime();
    cin>>n;
    //接下来是质因素分解
    int fnum = 0;//记录质因子个数
    if(n==1) {
        printf("1=1");
        return 0;
    }
    printf("%d=",n);
    int Sqr = (int)sqrt(n);
    for(int i = 0; i < num && prime[i] <= Sqr; i++){
        if(n % prime[i] == 0){//证明该素数是n的因子
            fac[fnum].x = prime[i];
            fac[fnum].cnt = 0;
            while(n % prime[i] == 0){
                fac[fnum].cnt++;
                n /= prime[i];
            }
            fnum++;
        }
    }
    if(n != 1){
        fac[fnum].x = n;
        fac[fnum++].cnt = 1;
    }
    for(int i = 0; i< fnum; i++){
        if(i != 0) cout<<"*";
        printf("%d",fac[i].x);
        if(fac[i].cnt != 1) printf("^%d",fac[i].cnt);
    }
    return 0;
}
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值