1.题目描述:
输入一行字符串,可能有空格,输出这个字符串
输入格式:
输入一行,包含一个字符串
输出格式:
输出一个字符串
样例输入:
kuaile AC
样例输出:
kuaile AC
AC:
#include<bits/stdc++.h>
using namespace std;
string s;
int main() {
getline(cin, s);
cout << s;
return 0;
}
2.专题说明:
在古罗马,“高卢战争”描述了凯撒使用加密来传递信息,即所谓的“凯撒加密”,这是一种替代加密。消息中的每个字母都被其后面的第t个字母替换。例如,当t=4时,加密规则是用原始字母后的第4个字母替换原始字母, 字母“A”后的第四个字母是“E”,而“A”被“E”取代,字母“z”后的第四个字母是“d”,而“z”被“d”取代。因此,“China”将被翻译成“Glmre”。请编写一个程序来加密输入的字符串,方法是将每个字母替换为后面的第t个字母。
输入格式:输入一个字符串并输入t
输出格式:标题中描述了输出格式。
示例输入1:
china 4
样本输出1:
glmre
示例输入2:
antDZYO 30
样本输出2:
erxHDCS
规定:
输入的字符串长度不超过100,只包含小写字母和大写字母。t<=260
AC:
#include <bits/stdc++.h>
using namespace std;
string a;
int t;
int main() {
cin >> a >> t;
t %= 26;
for (int i = 0; i < a.size(); ++i) {
if (a[i] >= 'a' && a[i] <= 'z') {
for (int j = 1; j <= t; ++j) {
if (a[i] == 'z')
a[i] = 'a';
else
a[i] = a[i] - 'a' + 'b';
}
}
else {
for (int j = 1; j <= t; ++j) {
if (a[i] == 'Z')
a[i] = 'A';
else
a[i] = a[i] - 'A' + 'B';
}
}
}
cout << a << endl;
}
3.题目描述
字符串是有大小关系的,那两个字符串的大小比较是以什么为依据的呢?
字符串的大小比较以“字典序”为依据。
所谓字典序,就是将两个字符串放到字典的对应位置,则出现在前的字符串小,后者大。
请尝试用for循环判断两个字符串的大小关系。
输入格式
输入共两行,每行一个无空格的字符串,分别表示两个需要比较大小的字符串s1和字符串s2。
输出格式
共两行,第一行输出字典序小的字符串,第二行输出字典序大的字符串。
样例输入
abd abc
样例输出
abc
abd
数据范围与提示
保证输入字符串长度不超过100
AC:
#include <bits/stdc++.h>
using namespace std;
string a, b;
int main() {
cin >> a >> b;
if (a < b)
cout << a << endl << b << endl;
else
cout << b << endl << a << endl;
return 0;
}
4. 题目描述:
还记得P9222"卡牌收集"吗?
现在小明觉得这个程序还有可以改进的地方。比如能否直接询问计算机卡牌的名称,就回复卡牌的攻击力呢?
输入格式:
第一行两个整数n,m。n表示卡牌的总数,m表示有m次询问;
接下去n行,每行一个字符串和一个整数,表示卡牌的名称和攻击力;
最后一行,有m个以空格间隔的字符串,依序表示询问的卡牌名称。
输出格式:
仅一行,以空格间隔的m个整数,按照询问顺序输出结果。
样例输入:
2 2 Luffy 1200 Zoro 1100 Zoro Luffy
样例输出:
1100 1200
约定:
1<=所有整数<=2000
字符串长度<=30
AC:
#include <bits/stdc++.h>
using namespace std;
int n, m;
map<string, int> ma;
int main() {
cin >> n >> m;
for (int i = 1; i <= n; ++i) {
string a;
int b;
cin >> a >> b;
ma[a] = b;
}
for (int i = 1; i <= m; ++i) {
string c;
cin >> c;
cout << ma[c] << ' ';
}
return 0;
}
5.题目描述:
输入两个字符串,验证其中一个串是否为另一个串的子串。
输入格式:
输入两个字符串, 每个字符串占一行,长度不超过200且不含空格。
输出格式:
若第一个串s1是第二个串s2的子串,则输出(s1) is substring of (s2)
否则,若第二个串s2是第一个串s1的子串,输出(s2) is substring of (s1)
否则,输出 No substring。
样例输入1:
abc dddncabca
样例输出1:
abc is substring of dddncabca
AC:
#include<bits/stdc++.h>
using namespace std;
int main()
{
char s1[200],s2[200];
scanf("%s %s",s1,s2);
int n1=strlen(s1),n2=strlen(s2);
if(n1>n2)
swap(s1,s2);
n1=strlen(s1),n2=strlen(s2);
int j=0,t=0;
for(int i=0; i<n2; i++)
{
if(s1[0]==s2[i])
{
int x=i;
for(int k=0; k<n1; k++)
{
if(s1[k]==s2[x])
{
t++;
x++;
}
else
break;
}
if(t==n1)
{
printf("%s",s1);
cout<<" is substring of ";
printf("%s",s2);
return 0;
}
else
t=0;
}
}
cout<<"No substring";
return 0;
}
6.题目描述:
给你三个字符串a, b, and c,将a里面出现的b串都替换成c串
输入格式:
输入一行,包含三个字符串 ,|a|,|b|,|c|<=1000,替换后的串长<=1000
输出格式:
输出一个替换后的字符串
样例输入1:
ababa aba abc
样例输出1:
abcba
样例输入2:
abcabcabc abc abcabc
样例输出2:
abcabcabcabcabcabc
AC:
#include <bits/stdc++.h>
using namespace std;
string check(string x, string y, string z) {
size_t pos = 0;
while ((pos = x.find(y, pos)) != string::npos) {
x.replace(pos, y.size(), z);
pos += z.size();
}
return x;
}
int main() {
string a, b, c;
cin >> a >> b >> c;
string s = check(a, b, c);
cout << s << endl;
return 0;
}
7.题目描述:
给你一篇小写的英文文章,你需要统计每种字母各出现了几次。
输入格式:
输入若干行,处理到文件结尾。
输出格式:
输出若干行,从小到大输出每种字符的出现次数,没有出现的字符不用输出。
样例输入:
abc abc def abab ccc ccc ccc
样例输出:
a:4 b:4 c:11 d:1 e:1 f:1
约定:
字符总个数<=100000
AC:
#include <bits/stdc++.h>
using namespace std;
int main()
{
string a;
int s[26]={0};
while(cin>>a){
for(int i=0;i<a.length();i++){
s[a[i]-'a']++;
}
}
for(int i=0;i<26;i++){
if(s[i]) cout<<char('a'+i)<<":"<<s[i]<<endl;
}
return 0;
}