【归并排序求逆序对】poj1007

47 篇文章 0 订阅
DNA Sorting

Description

One measure of ``unsortedness'' in a sequence is the number of pairs of entries that are out of order with respect to each other. For instance, in the letter sequence ``DAABEC'', this measure is 5, since D is greater than four letters to its right and E is greater than one letter to its right. This measure is called the number of inversions in the sequence. The sequence ``AACEDGG'' has only one inversion (E and D)---it is nearly sorted---while the sequence ``ZWQM'' has 6 inversions (it is as unsorted as can be---exactly the reverse of sorted). 

You are responsible for cataloguing a sequence of DNA strings (sequences containing only the four letters A, C, G, and T). However, you want to catalog them, not in alphabetical order, but rather in order of ``sortedness'', from ``most sorted'' to ``least sorted''. All the strings are of the same length. 

Input

The first line contains two integers: a positive integer n (0 < n <= 50) giving the length of the strings; and a positive integer m (0 < m <= 100) giving the number of strings. These are followed by m lines, each containing a string of length n.

Output

Output the list of input strings, arranged from ``most sorted'' to ``least sorted''. Since two strings can be equally sorted, then output them according to the orginal order.

Sample Input

10 6
AACATGAAGG
TTTTGGCCAA
TTTGGCCAAA
GATCAGATTT
CCCGGGGGGA
ATCGATGCAT

Sample Output

CCCGGGGGGA
AACATGAAGG
GATCAGATTT
ATCGATGCAT
TTTTGGCCAA
TTTGGCCAAA
 
求出每个串的逆序对的个数,然后按逆序对个数对DNA串进行排序。
求逆序对的方法是用归并排序
#include <iostream>
#include <cstdio>
#include <cstring>
#include <algorithm>
using namespace std;
struct ty
{
    long x;
    string s;
    inline bool operator < (const ty& b) const
    {
		if (x < b.x) return true;
			else return false;
    }
};
long n, m;
string t;
ty a[200];
long sum;

void merge1(long l, long mid, long r)
{
    char tmp1[200] = {"\0"}, tmp2[200] = {"\0"};

    for (long i = l; i <= mid; i++)
    {
        tmp1[i] = t[i];
    }

    for (long i = mid + 1; i <= r; i++)
    {
        tmp2[i] = t[i];
    }
 
    tmp1[mid + 1] = 'Z';
    tmp2[r + 1] = 'Z';
    long i = l , j = mid + 1;


    for (long k = l; k <= r; k++)
    {
        if (tmp1[i] <= tmp2[j])
        {
            t[k] = tmp1[i];
            i++;
        }
        else{
            t[k] = tmp2[j];
            sum +=mid - i + 1;
            j++;
        }
    }
}
void merge_sort(long l, long r)
{
    if (l <r)
    {
        long mid = (l + r) / 2;
        merge_sort(l, mid);
        merge_sort(mid + 1, r);
        merge1(l, mid, r);
    }

}
long nixudui(long i)
{
    sum = 0;
    t = a[i].s;
    merge_sort(0, m - 1);
    return sum;


}
int main()
{
    freopen("G.in","r",stdin);
    while (scanf("%d%d\n", &m, &n) != EOF)
    {
        for (long i = 1; i<= n; i++)
        {
            cin >> a[i].s;
            a[i].x = nixudui(i);
        }
        sort(a + 1, a + 1 + n);
        for (long i = 1; i<= n; i++)
        {
            cout << a[i].s<<endl;
        }
    }

    return 0;
}

  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
DNA Sorting Time Limit: 1000MS Memory Limit: 10000K Total Submissions: 34868 Accepted: 13480 Description One measure of ``unsortedness'' in a sequence is the number of pairs of entries that are out of order with respect to each other. For instance, in the letter sequence ``DAABEC'', this measure is 5, since D is greater than four letters to its right and E is greater than one letter to its right. This measure is called the number of inversions in the sequence. The sequence ``AACEDGG'' has only one inversion (E and D)---it is nearly sorted---while the sequence ``ZWQM'' has 6 inversions (it is as unsorted as can be---exactly the reverse of sorted). You are responsible for cataloguing a sequence of DNA strings (sequences containing only the four letters A, C, G, and T). However, you want to catalog them, not in alphabetical order, but rather in order of ``sortedness'', from ``most sorted'' to ``least sorted''. All the strings are of the same length. Input The first line contains two integers: a positive integer n (0 < n <= 50) giving the length of the strings; and a positive integer m (0 < m <= 100) giving the number of strings. These are followed by m lines, each containing a string of length n. Output Output the list of input strings, arranged from ``most sorted'' to ``least sorted''. Since two strings can be equally sorted, then output them according to the orginal order. Sample Input 10 6 AACATGAAGG TTTTGGCCAA TTTGGCCAAA GATCAGATTT CCCGGGGGGA ATCGATGCAT Sample Output CCCGGGGGGA AACATGAAGG GATCAGATTT ATCGATGCAT TTTTGGCCAA TTTGGCCAAA Source East Central North America 1998
归并排序是一种经典的排序算法,它通过将待排序的序列递归地划分成较小的子序列,然后将这些子序列进行合并,最终得到一个有序的序列。在归并排序的过程中,可以通过统计逆序对的数量来评估序列的有序程度。 使用归并排序逆序对的基本思想是:在合并两个有序子序列的过程中,如果左子序列中的元素大于右子序列中的元素,则构成了一个逆序对。在合并过程中,统计逆序对的数量,并将两个子序列合并成一个有序序列。 具体步骤如下: 1. 将待排序序列不断二分,直到每个子序列只有一个元素。 2. 逐层合并相邻的子序列,并在合并过程中统计逆序对的数量。 3. 重复步骤2,直到所有子序列合并成一个有序序列。 以下是使用归并排序逆序对的示例代码: ```python def merge_sort(arr): if len(arr) <= 1: return arr, 0 mid = len(arr) // 2 left, count_left = merge_sort(arr[:mid]) right, count_right = merge_sort(arr[mid:]) merged, count_merge = merge(left, right) return merged, count_left + count_right + count_merge def merge(left, right): merged = [] count = 0 i, j = 0, 0 while i < len(left) and j < len(right): if left[i] <= right[j]: merged.append(left[i]) i += 1 else: merged.append(right[j]) j += 1 count += len(left) - i merged.extend(left[i:]) merged.extend(right[j:]) return merged, count ``` 使用上述代码,可以通过调用`merge_sort`函数来解给定序列的逆序对数量。函数返回排序后的序列以及逆序对的数量。
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值