maven子工程无法引用父工程POM依赖包解决方案

网上查了很多资料,最终才发现是本机使用的IDEA和MAVEN版本不一致导致的,也可能是MAVEN本身的版本有问题导致的

本机JDK版本1.8.0_74
IDEA版本2018.3
只需将MAVEN的版本从3.6.1改为3.3.9
即可解决

此外还要注意父工程POM有
在这里插入图片描述
且父工程依赖包写在dependencies标签里,而不是dependencyManagement里
在这里插入图片描述

已标记关键词 清除标记
©️2020 CSDN 皮肤主题: 游动-白 设计师:上身试试 返回首页