ZOJ - 3932 Handshakes

Last week, n students participated in the annual programming contest of Marjar University. Students are labeled from 1 to n. They came to the competition area one by one, one after another in the increasing order of their label. Each of them went in, and before sitting down at his desk, was greeted by his/her friends who were present in the room by shaking hands.

For each student, you are given the number of students who he/she shook hands with when he/she came in the area. For each student, you need to find the maximum number of friends he/she could possibly have. For the sake of simplicity, you just need to print the maximum value of the n numbers described in the previous line.

Input

There are multiple test cases. The first line of input contains an integer T, indicating the number of test cases. For each test case:

The first line contains an integer n (1 ≤ n ≤ 100000) -- the number of students. The next line contains n integers a1, a2, ..., an (0 ≤ ai < i), where ai is the number of students who the i-th student shook hands with when he/she came in the area.

Output

For each test case, output an integer denoting the answer.

Sample Input

2
3
0 1 1
5
0 0 1 1 1

Sample Output

2
3
思路:如果进来的那个人握手次数比最大的那个人还大,那他就是握手次数最多的人。否则,握手次数最多的那个人握手次数加一(相当于新进来的那个人跟他握手了)。
#include <cstdio>
#include <iostream>
#include <cmath>
#include <string>
#include <cstring>
#include <queue>
#include <algorithm>
#include <map>
using namespace std;
#define ll long long
const int inf = 0xffffff;
const int maxn = 1e5+8;
int t, n, miao, sum;
int main()
{
    scanf("%d", &t);
    while(t--)
    {
        scanf("%d", &n);
        sum = 0;
        while(n--)
        {
            scanf("%d", &miao);
            if(miao>sum)
                sum = miao;
            else if(miao>0) sum++;
        }
        printf("%d\n", sum);
    }
    return 0;
}

 

转载于:https://www.cnblogs.com/RootVount/p/10706272.html

评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值