SDNU 1212.判断升序(水题)

Description

实现public static boolean isSorted(int[] table)

判断整数数组元素是否已经按升序排序。

Input

一列数,需要判断的数组元素。

Output

如果已经排序输出YES

如果没有排序输出NO

Sample Input

1
2
3
4
5
6

Sample Output

YES

Hint

import java.util.*;

public class Main{

   public static void main(String args[]){

  Scanner cin = new Scanner(System.in);

  int a, b;
  b=-1;
  while (cin.hasNext()){

  a = cin.nextInt();

              if(??????????){
                ????????;
               ????????????????????;
              }
 ????????????;

                        }

 if(!cin.hasNext())
  ????????????????????????

  }

}


Source

#include <cstdio>
#include <iostream>
#include <cmath>
#include <string>
#include <cstring>
#include <algorithm>
#include <queue>
#include <vector>
#include <map>
using namespace std;
#define ll long long

int num[100000+8], x;
bool flag = 1;

int main()
{
    while(~scanf("%d", &x))
    {
        int id = 0;
        num[id] = x;
        if(!id && num[id]<num[id-1])flag = 0;
        id++;
    }
    if(flag)printf("NO\n");
    else printf("YES\n");
    return 0;
}

 

转载于:https://www.cnblogs.com/RootVount/p/10991376.html

  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值